A place for customers to chat about Realmac and its products - RapidWeaver, Clear and Ember!

urban header - replace with image - need to know size & how to - thanks!

heatherheather NYCPosts: 35Members
hi there,
i created a site using the urban theme - http://www.danielgracieusa.com - and received some excellent help from the forum. i'd like to replace the header with an image but do not know the size of the header or how to do this. i checked through the topics to see if someone else had asked this question, but couldn't find a thread. i checked the site setup and page setup to see if the header size was mentioned, but i couldn't find it if it was mentioned. would greatly appreciate help. thanks!
heather

Comments

  • milomacmilomac Warwickshire, UKPosts: 166Members
    edited 12:14PM
    Hi Heather

    Paul Bradforth has written an excellent tutorial on this topic which is available here.

    Rose
  • heatherheather NYCPosts: 35Members
    edited 12:14PM
    on 1233701424:
    Hi Heather

    Paul Bradforth has written an excellent tutorial on this topic which is available here.

    Rose

    Really great help, thank you. Worked well on eight of ten pages. I can't get the image to appear in the header in two of the ten pages. Here is the site: http://www.danielgracieusa.com

    The two pages where the image won't appear are the MMA Fights ( http://www.danielgracieusa.com/page2/page2.html ) page and the Training ( http://www.danielgracieusa.com/page3/page3.html ) page. Could you please give me some insight on why they won't load? I published the changes and the eight loaded successfully. When the two wouldn't, I cleared the publishing cache and re-published to no avail.

    Thanks very much!
    Heather
  • milomacmilomac Warwickshire, UKPosts: 166Members
    edited February 2009
    Hi Heather

    If you followed the instructions precisely for each page I can see no reason why all the header images shouldn't appear in your site. The fact that the original image is now gone and the new image isn't showing implies to me that some of the page assets (ie the missing images) haven't uploaded properly. The fix for this is normally File>Re-publish all Files. I know that you have re-published but I'm not sure if you've re-publishing everything. Try this and see if it fixes the problem.

    There is an alternative 'quick and dirty' way to change the header image that you might want to try if you're still having trouble. This involves replacing the theme's original header images with images of identical size and re-naming the new images with identical names to the original images. Obviously, duplicate the theme first. This is an especially good solution if you are only going to be using one header image but it isn't great if you are going to be using a number of different images (as you are) since you can only replace the number of built in images that exist for the theme. Whilst it's not perfect, it is one solution that might just work for the two images you're having trouble with. :-)

    Hope this helps.

    Rose
  • heatherheather NYCPosts: 35Members
    edited 12:14PM
    on 1233784989:
    Hi Heather

    If you followed the instructions precisely for each page I can see no reason why all the header images shouldn't appear in your site. The fact that the original image is now gone and the new image isn't showing implies to me that some of the page assets (ie the missing images) haven't uploaded properly. The fix for this is normally File]Re-publish all Files. I know that you have re-published but I'm not sure if you've re-publishing everything. Try this and see if it fixes the problem.

    There is an alternative 'quick and dirty' way to change the header image that you might want to try if you're still having trouble. This involves replacing the theme's original header images with images of identical size and re-naming the new images with identical names to the original images. Obviously, duplicate the theme first. This is an especially good solution if you are only going to be using one header image but it isn't great if you are going to be using a number of different images (as you are) since you can only replace the number of built in images that exist for the theme. Whilst it's not perfect, it is one solution that might just work for the two images you're having trouble with. :-)

    Hope this helps.

    Rose

    Dear Rose,
    Hi there. Thanks again for your help. I had made a mistake when I wrote the css. The image is a JPG - I had it as a jpg. Your help and the tutorial were great.
    Heather
Sign In or Register to comment.