Armadillo and the mysterious dot!


(Rob Beattie) #1

@nimblehost

I’m starting to get on very well with Armadillo and really like it. However, it appears to have inserted a specious ‘dot’ where I don’t want one at the beginning of my tag list.

The only clue I have to something going wrong is that although I went back and deleted all my tags from the Settings page, when I returned to the blog posts to re-insert them from scratch, I noticed that one - gazette - still appeared in the drop down list in Tags at the bottom of the Add new post window. I couldn’t get rid of it.

I can’t show the site because it’s hidden at the request of the client but fortunately, you can see the exact effect I’m talking about here - http://tigerofthestripe.co.uk/blog/ - above the first tag (Brexit). There’s an orphan dot at the top of the tag list doing nothing. (this blog is nothing to do with me - it’s by another RW user on the forum).

Any ideas?

Thanks

Rob


(Mathew Mitchell) #2

Robb: I’m sorry I can’t help you. I ran into the same situation 2-3 years ago. But I don’t remember what the fix was!

I don’t know that this will help at all, but perhaps go back to Settings page and delete the offending dot. Then log out. Then log in. (Kinda like a computer restart.)


(Rob Beattie) #4

Hi Matthew, I deleted all the Tags I could find in Settings. There wasn’t a dot so I couldn’t delete it. If you look at the code it’s an empty <li> item so I’m not sure where to go from here. It doesn’t appear in my other Adillo blog here - http://www.riverrunning.co.uk/ so I wonder if it’s an odd theme-related thing?

It’s not a killer problem so hopefully @nimblehost will mosey along at some point and enlighten us!

Rob


(Rob Beattie) #5

Let’s see if @nimblehost pipes up with one!


(Mathew Mitchell) #6

Rob: Ah, yes, that rings a bell (empty list item). I’ve gone through my email archives and still can’t find the answer. I know Jonathan helped me sort it out. I suppose it might be theme-related but that’s not ringing a bell.


(Dylan Banks) #7

Not sure if this works and if it’s the right way if it does but try this:

.blog-tag-cloud li:first-child {
display:none;
}


(Rob Beattie) #8

Bosh! Get in!

I’ll let you know if it breaks the whole site but for now it’s working perfectly. All hail the mighty Rapidweaver forum and - in this instance - @dylan.

:sunglasses:


(Jonathan Head) #9

The “dot” in this case is likely just the CSS formatting for the list item, so it won’t show up in the Settings tab as a dot under Tags - rather, it will be a completely empty entry that you’ll need to delete (possibly a bit tricky, because since it would be an empty tag, it will be hard to spot).

Let me know if that helps.


(Rob Beattie) #10

Sorry Jonathan. I have no idea how I’d go about deleting an entry that I can’t see. If you can give me a clue what to look for, I’d appreciate it.

Thanks

Rob


(Jonathan Head) #12

See attached screenshot - it will appear with a “click to edit” message, and if you hover over the tag, the red “delete” option will appear as well.


(Rob Beattie) #13

Thanks to all. I only have three tags in that list and no ‘empty’ ones so there doesn’t seem to be anything to remove. Grrr.

Meantime @dylan’s CSS has done the trick (thanks again) so I’ll chalk this one up with corn circles and that weird thing that’s washed up on the Indonesian beach…:sunglasses:


Formatting Armadillo Archive