Cannot publish - README file issue?

I am suddenly getting a publishing issue with an established website (RW v 8.9.1 on Big Sur), with the RW upload stopping at a README.md file consistently. I have tried exporting the site then using an FTP client, but the same issue occurs. There are evidently over 30 of these files in the project - perhaps one of them contains something the server does not like but how do I know, and can anyone think of a solution? If these files are not needed then I suppose I could delete them all before FTP, but I would rather get to the bottom of it so I can publish normally again. I had not made any significant changes to the site and was doing a periodic Re-publish All Files, so perhaps this file was part of a Stack update or something and I am not alone.

If you can’t publish to a local folder, then your are probably correct in that there is some resource causing the issue. It’s a process of elimination. So you may want to bookmark your publishing settings and choose to publish to a local folder until you get it worked out.

The log files might give you a clue as to what exact file is causing the problem.

Preferences > Publishing > Enable Upload Logging

You can clear and check the logs from the help menu.

If you don’t know what page is causing the issue, you can right-click on each page and select publish page one at a time. .

1 Like

Yes, good advice - thank you. I will launch an investigation!

Cheers Doug

OK, publishing one page at a time reveals that there are two pages which produce this error, which are both RW native Contact Form pages. There is no README file available in the FTP folders, so I guess this is being generated behind the scenes. I can put together forms using another resource as a work around, but perhaps this needs looking into at Realmac?

I never have used the built-in contact form, but I can’t even imagine why they would have anything like a ‘readme.md’ file. That’s a markdown file (.md) and the contact form doesn’t use MarkDown.

I would guess that the bad file(s) might be in the resources tray and for some reason when publishing those pages it’s trying to publish the resources. Just a guess.

I’d be curious to see what happens if you mark those pages as draft (so they don’t publish and then select publish all files from the drop-down publish menu.

1 Like

Hmm, I see what you mean. So, just did as you suggested and the site published fine, with less than half the file count as previously so there seem to be a lot of files associated to those two pages.

Ooh, just checked the actual site and am seeing this:

Fatal error: Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.4.0”. You are running 7.2.34. in /home/andrewlo/public_html/stmaryscreativespace.co.uk/rw_common/plugins/stacks/total-cms/vendor/composer/platform_check.php on line 24

Could this be the seat of the problem? Just checked using Server Info stack and my server is using PHP 7.4.21.

Not sure where the message came from. Was that on one of those contact pages?

I don’t know what you might be using that uses “Composer”? Think that might be a different issue.

Since removing those two pages stopped the problem with publishing and they’re both RW contact pages, I guess that there is something messed up with those pages. The built-in contact form is pretty simple, and unless you’ve added a bunch of stuff, it shouldn’t add that much to publishing.

I’d probably just rebuild them one at a time and then test them pretty thoroughly.

You might want to provide a URL to the page that’s giving you that Composer error.

Actually, that is just effecting the home page (https://stmaryscreativespace.co.uk/) so perhaps a different issue, yes, and references to Total CMS so will see if I can narrow it down to that content. I have posted a question on Joe Workman’s Weaver Space forum too. Both contact pages are very simple and have been working for years, but yes easiest thing is to ditch and rebuild, so that is my evening’s entertainment sorted. Strange that this as all come out of nowhere, but hopefully I can get to the bottom of it.

Okay, so that makes sense as to being a different issue with totalCMS. Since you said that the server info is showing that you’re running 7.4.2. If you have a page that shows the server info that might help Joe figure out what’s going on.

@joeworkman does monitor this forum aswell. Just tag him like I just did.

I don’t have a clue as to what could have happened to the contact pages, but since they’re simple at least it shouldn’t take long to rebuild.

I got @androo sorted out over on the WS community site…

1 Like

Actually it seems the server was on 7.2, so updating to 7.4 solved that, with Joe’s help. He spotted something else too, so there will be a tweak in the next release of Easy CMS. Just working on a new form with Formloom, rather than using the native page. We shall see.