Error 500 for Community site

Hey @ben and @dan – Looks like there’s a problem on the Community site…

Fixed!

the server now is down ( 15:16 +1 Rome ) https://rapidweavercommunity.com

Same here as well.

Works for me now fyi.

1 Like

yes, same issue happened twice - won’t bore you with the details, but we are all fixed now!

Looks like it is back again in some searches:

https://rapidweavercommunity.com/search?q=alloy

This is a different issue - a 500 server error is just a generic message that there’s an issue server side.

I know what this issue is, and it is only affecting certain searches.

I was ill last week, but I hope to have it fixed sometime this week.

Cool. I just thought I’d report it, whatever the cause, as I got an email from a RW user about it.

Feel better!

@ben & @dan: Just a heads up, this still looks like it is a thing when searching on this Community site:

@dan @ben – in addition to the Error 500 bug above I’m now getting this nondescript “Server Error” when trying to upload a new Screenshot.

29%20PM

Addendum: It looks like this error only occurs when trying to add a screenshot through this link:

Ben is looking into it this week…

Cheers for the heads-up!

Thanks
Dan

Thanks Dan! Appreciated!

This is top of my list to fix! I think I know what this is and hopefully I can get a fix online early next week.

Thanks @Ben!

Could you try this again — from my testing I believe this is now fixed.

If you’re still having issues, could you send me the image you’re trying to upload?

I am working on getting the fix for the search error online today.

I’ve actually already uploaded my image. I ended up doing so by editing the product and uploading the image directly there. I suspect the reason it was not working through this link…

Is because it was not associating it with any particular product when you upload, as it doesn’t have a way to specify the product on this screen…

I attempted to upload via that link again just now as a test, but still get the same error. I suspect that we’re just not supposed to upload to that area, correct?

@ben – you’re going to hate me, but I ran across some more Error 500s tonight. Developer pages seem to go nowhere now.

Example:
https://rapidweavercommunity.com/addons?developer=elixir

That link, and others like it, return the dreaded Error 500 page:

Others I saw with this problem:

https://rapidweavercommunity.com/addons?developer=yourhead-software
https://rapidweavercommunity.com/addons?developer=joeworkman
https://rapidweavercommunity.com/addons?developer=wondrousss
https://rapidweavercommunity.com/addons?developer=yabdab

…and many more. Guessing it is just an overall problem. Also noticed that when clicking on a product sometimes it would go to a page like this and wouldn’t show anything unless you refresh the page a second time:

Ran into all of these problems in both Chrome and Safari.

Here for me too, results from search are all broken as well as a direct link to my products:
https://rapidweavercommunity.com/addons?developer=weavers-kingdom

@ben is looking into it today, fingers crossed it’ll be back up and working soon.