General malfunction


(Terry E Hubbard) #1

Hi all,
Forgive me if i don’t post detailed info, I simply cannot wrap my head around it. Here’s why. I have been using RW for a few years, with little problems, but then all of a sudden, everything went haywire.

I can no longer edit certain functions in Header Helper.
My image dimensions all changed in the basic stack layout, and i can’t get them back.
All of my pages changed, and I cannot get them back to where i want them.
As soon as i open them in RW they change or are corrupted.
A cannot edit/change my header image.
I cannot edit/change the header text.
The over -all functionality of the software seems to have altered, and no longer functions as it did only days ago.

No, I have no malware or viruses.

I am not inclined to have to start all over from scratch, but if I want to update my site, that’s probably what I am going to have to do.

I looked in vain for some kind of help/tutorial for header helper, as that seems to be the locality of the problem, but could find nothing except links to buy the new upgrade. As cheap as it is, I am not inclined to do that on the vague hope that it will fix whatever is broken.

Just a few days ago everything was working fine. The zappo powie -major malfunction. I have not upgraded my OS since Yosemite, and the last stacks upgrade I did was months ago.

I am currently upgrading to see if it helps. But I would really appreciate some kind of tutorials for some of this. I’d also appreciate stuff not changing without my consent or knowledge…

Well apparently the upgrade won’t work either. ERROR! ERROR! Maybe RW has died!


(Terry E Hubbard) #2

Update: Tried the new version 6 as trial, and everything is worse! And the app crashed after about 2 minutes. Guess it’s time to look for alternatives. Rapidweaver has gone bye-bye.


(Brad Halstead) #3

@T.E.H

Hey Terry, welcome to the forums.

Just trying to get a little background here…

RE: Yosemite, I assume you have 10.10.5 installed? All security updates? Did you install the latest version of iTunes or is that still the version that came with Yosemite…

What version of RapidWeaver were you working with 5.?.?.

RapidWeaver 5.4.1 is available for download directly here

Do you have YourHead Stacks 2, 2.x or 3 installed?

Have you updated all your themes, stacks and plugins? Any of the LogHound must be done manually by visiting their site and downloading V5 or V6 version of the stacks.

Header Helper is currently v 1.4.0 on their website, don’t know if a paid upgrade or not.

Have you tried a reboot?

Have you tried disk first aid, repair permissions and verify disk?

Support is always available from support@realmacsoftware.com.

Hope that gives you some direction and good luck

Brad


(Terry E Hubbard) #4

Tried 5.4.1 - not sure what you mean by “YourHead” stacks. But I think I have vs 2x stacks- I have updated to the point where the next updates are requiring fees. I refuse to be held hostage :slightly_smiling:

Mac updates are all in except El Capitan- and I had so much trouble with Yosemite, I decided to wait a few.

I haven’t tried the disk repair/verify yet, tho I will now. -It wasn’t that long ago I did.

The point is that -as i mentioned- the last time i used RW was barely over a week ago. No changes (at least known by me) at all until today, and that exclusively (as far as I can tell short of testing all my apps one by one) was Rapid Weaver. As I also mentioned, I even tried the new 6 dloaded right from the RW site, and ran as a trial. Not only did it not correct the problem, but it created even more!

Thanks for the reply tho, and i’ll let you know if the disk repair permissions help.


(Terry E Hubbard) #5

Ok, repairing permissions etc made no diff.
here’s a couple screen shots to illustrate one -just one of the problems;

This one is the actual page on the site - I haven’t uploaded new files.

This next one is the html that RW exported


(Terry E Hubbard) #6

as you can see, RW changed the sizing and alignment, and I cannot edit/change it to the original. Header Helper will not let me edit, and RW itself is tweaky and I cannot for the life of me change dimensions of either the pictures or the stack frame to get it back to the simple, centered alignment of everything.

It is notable that when i tried the vs 6 trial, all my theme info was lost as well. Thank goodness i was able to cancel the export before it totally wiped my themes out of the project.


(Brad Halstead) #7

Hi Terry @T.E.H

I’m not doubting you have an issue at all, I just don’t think it is RapidWeaver causing it, it is likely something else on the system that has failed, arbitrarily overwritten something or removed something that RW requires to run properly…

Hmmm (second to last rain cell burning up here…), do you have anything like MacKeeper installed or any other ‘optimization’ apps? These advertise themselves to be good for your computer and remove unnecessary files, however, I have tried some of them and they just mess up the system as some apps require the language modules as an example or they won’t function correctly

The only other idea I have is that maybe some RAM or your HDD is starting to fail? Perform a system diagnosis maybe?

Ahhh… I see your images now… to me, somewhere along the line of editing, the sites content got edited to full width and the Theme requires a certain content size by the looks of the images to me… but without seeing the project or having the mentioned stacks, I am at a loss as to where to direct you from here…

Re: upgrading to V6 trial, there is a process to follow (in the RapidWeaver FAQ area of Realmac Softwares website). This will allow you to import themes, stacks and plugins from RW5.4.1 and projects from 5.4.1 as long as the update process is followed, and Stacks V3.x from YourHead Software is required.

Other than that, I am not sure where to lead you and would recommend you mention this thread in an email to support@realmacsoftware.com where they can see what was tried and maybe offer other potential solutions…

HTH - Best I can do…
Brad


(Terry E Hubbard) #8

Just so you know. I figured out most of the problems. The above problems were related -as you said- to theme parameters. Somehow the width adjustment in the page inspector ‘styles’ reset to smaller dimensions.

I also figured out how to change the header image, and edit the header text, though that was a bit un-user-friendly. Changing code in the CSS is not the kind of ‘ease of use’ I’d like to have. But no matter. I can continue to use my work for the moment.

Thanks for the input.


(Brad Halstead) #9

Thank you for the update @T.E.H :+1:


(Philip Beck) #10

The link to the RW FAQs is 404.


(Brad Halstead) #11

@Philipnb

Yes, they are rebuilding their website, I do not know if there is a new URL for it. Please contact support@realmacsoftware.com

Brad


(Brad Halstead) #12

@Philipnb

Make sure RapidWeaver 5 is updated to 5.4.1 (Available from release notes page on the RMS website)
Make sure Stacks is updated to 2.7.1 (Available from YourHead)
Update your stacks from within Stacks app with RW 5.4.1 open
Restart RW 5.4.1

This is important:

Be sure to open and save each of your RW5.x projects in RW 5.4.1 and SAVE them. Miss this step and the projects won’t open properly in RW6.x

Then they should import into RapidWeaver 6 fairly painlessly.

As for Stacks, the only issues I am aware is that you had to manually upgrade the LogHound Stacks to Version 6, but as he is out of business and Yourhead has taken them over, I do not know when the info for the stacks will be available, but if you contact YourHead software, I am sure they can hook you up with V6 of the stacks.

Wouldn’t you know it, I did a Google Search and found the page, here is the link

Hope that helps.
Brad