How do you add a new font to a theme in RW8?


(BRHolmes) #1

This post was flagged by the community and is temporarily hidden.


(Rob Beattie) #2

The easiest way would be to use a Google font like Nunito, which is fairly close to Futura. Google fotns are free and easy to add to an RW site.

If you’re using the Stacks plugin to create your pages then something like the free Fontstack (https://stacks4stacks.com/fontstack/) will work.

If you’re not using Stacks pages then I think this (https://onelittledesigner.com/rapidweaver/kb/adding-custom-fonts-in-rapidweaver/) may help.

Rob


(BRHolmes) #3

Thanks.

Nunito sure ain’t Futura…

I’ve checked the Google Fonts page, and it’s there. The font shows this disclaimer:
“Available from these external foundries”

Does this mean there’s an extra step here somewhere or if I work out how to use Stacks > Fontstack will this plugin be able to do what I am wanting it to do?

I will read the link you posted as well - much appreciated :slight_smile:

Thanks again!


(LJ) #4

Joe Workmans font pro stack is a very full featured solution - however, maybe overkill and bit too expensive for just one font on one website. https://joeworkman.net/rapidweaver/stacks/font-pro/


(Jannis from inStacks Software) #5

https://instacks.com/customfontstack/ will do it for you.


(BRHolmes) #7

This is sort of diabolical.
I can add text and change the font, but this stack doesn’t have an obvious way of changing the header, “contact” and other titles which this Theme uses.
If you look at the preview here:
https://www.rapid-ideas.com/previews/whitespace/
You’ll see a little White Space Elegant and Minimal" header up top.
I have no idea how to change the font of these types of elements.
The instacks.com instructions are far from clear how to do this.
“In order to change the font of title, slogan, footer, and navigation bar, the text of these fields has to be sourounded [sic] by span tags with additional font-family settings. This can be done in the Page Inspector or general settings of the project. See the third screenshot in the settings and the demo page for reference.”
The “third screenshot” shows nothing of the sort. The demo page doesn’t help.

The General (settings) component of the RW8 interface has nowhere to input code. The instructions make no sense.

Is this stack out of date?

I’m really hoping the $50 I just spent wasn’t for nought… I am sure this is just be being a novice but heck, this is far more complex than anticipated…


(BRHolmes) #8

Plus -
I have added all custom fonts (in all requisite formats) following the instructions up to “call in the stylesheet” according to these instructions:

I have tried adding this code:

[left arrow, backslash] href="%resource(fonts/stylesheet.css)%" rel=“stylesheet” media=“all” type=“text/css” [backslash, left arrow]

everywhere. It makes NO difference.
When I try adding any code such as:

header h1#title {
font-family: ‘BebasNeueRegular’ !important;
}

or

font-family: ‘FuturaStd-Bold’, FuturaStd-Book, FuturaStd-BookOblique;

or

h3 {font-family: ‘FuturaStd-Bold’, FuturaStd-Book, FuturaStd-BookOblique;}

…all that happens is this appears as text at the top of my page :frowning:


(scott williams) #9

See those curly quotes in your code? That will break it. You need to turn that off in prefs.


(BRHolmes) #10

Thanks. By “curly quotes”, do you mean: this thing: { ?

Also, it seems that if I type ANY code at all which starts with h1 or header… or anything else I have tried which is not that line of CSS stylesheet related code, it simply shows up in my page as text. It behaves as text.

Which of the preferences do I switch off - there is no pref titled "turn off curly quotes: haha - I am new to this so need specifics:

These are the prefs:

Enable Web Dev Tools
Enable External Preview Auto Reload
Render PHP…
Use Smart Quotes
Enable Code Completion
Use Generic Page Icons
Show Alert when changing filenames


(David) #11

Smart Quotes are also called Curly Quotes - turn that option off. You may want to turn them off in System Prefs > Keyboard > Text as well.

Also a good idea to “Paste as Plain Text” whenever copying and pasting code or text in RW.


(BRHolmes) #12

It’s already turned off by default, so evidently has nothing to do with why I can’t get this theme / RW8 to recognise my code to use my preferred fonts… :frowning:


(BRHolmes) #13

Ok, managed to get https://instacks.com/customfontstack/ working… somewhat awkardly - it’s page by page as opposed to universal, and the whole stack way of getting it to do something felt strange - mostly got there.
The contact form is still a problem, when I create a contact form, this page will not bring up any stack options at all.


(Jannis from inStacks Software) #14

CustomFont Stack is free, so you’re not talking about that stack I guess. I will reply to your email.
Thanks.


(BRHolmes) #15

I meant $50 spent on the Stacks plugin, not your free plugin… :slight_smile:


(BRHolmes) #16

Email would be best, but in case this is faster:

A weird thing I am now grappling with:

Custom base applied - no probs

Custom Font applied - no probs

I click on the outer frame (Custom base) to see the

“Custom Font” options, establish local font files location,

state the font family and import the requisite file types.

I type away, test it out -

All fine.

Now, when I cut and paste my text from

my Vimeo page (description text), the font

does not update. It remains exactly as it appears

on my Vimeo page, even though I can see that

all of the Custom Font options are correct.

I have tried copying the working base / font

frame and then deleting and pasting in text.

Same thing.

How do I get it to recognise the settings I have input

when I cut and paste text?

I even tried using “plain text” from a plain text email.

Didn’t work…


(BRHolmes) #17

Weird! I just tried same cutting and pasting a line of text from this page.
The font settings were almost correct - for some reason the colour was not correct, but the font itself was correct.
Next I tried cutting and pasting text from my Vimeo page and yet again all settings failed as above.


(Jannis from inStacks Software) #18

You have to copy and paste without formatting:

Or remove the styling from RW with a menu option (not at my Mac currently).


(Doug Bennett) #19

When you paste into RapidWeaver use paste as plain text.

menu>edit>paste as plain text
Or keyboard shortcut.
opt+cmd+v


(BRHolmes) #20

Found in my mailbox here at the forum:

" Your post was flagged as spam : the community feels it is an advertisement, something that is overly promotional in nature instead of being useful or relevant to the topic as expected.

Multiple community members flagged this post before it was hidden, so please consider how you might revise your post to reflect their feedback. You can edit your post after 10 minutes, and it will be automatically unhidden."

Jesus. Talk about forum fascism! Clearly the links I posted were to provide references and context.
Between this and the “woah! don’t post more than three times in an hour!” rule - this forum is over-moderated. Far out.

Christ almighty. Half of my posts in this thread have been hidden. Anything containing an “Instacks” link has been hidden because the robots who run this place don’t read, only look for links to flag as possible spam advertising. Bad form, bad for users and fails to take context into account.

I have literally never come across this level of careless policing of a public forum before. Big Brother much, realmacsoftware?


(BRHolmes) #21

Posts hidden by the nazi-bots of this forum:

Hi,

I just started using RW8 today - it’s excellent. I’m a novice and already I have just about got my website together.

I would like to make one customisation to the theme I am using:

(Link to White Space theme - removed by the bots here)

“White Space” is a RW7 theme but of course works just fine in RW8.

I would like to add Futura and Futura bold: Not included in the Theme specific fonts for White Space.

  1. How do I do this?
  2. Will doing this make my page less likely to load my desired font when it is viewed? ie does an “added” font behave less reliably than the fonts included in a Theme?

Thanks!

Plus -
I have added all custom fonts (in all requisite formats) following the instructions up to “call in the stylesheet” according to these instructions:

(One little designer link - removed by the bots for no good reason)

I have tried adding this code:

[left arrow, backslash] href="%resource(fonts/stylesheet.css)%" rel=“stylesheet” media=“all” type=“text/css” [backslash, left arrow]

everywhere . It makes NO difference.
When I try adding any code such as:

header h1#title {
font-family: ‘BebasNeueRegular’ !important;
}

or

font-family: ‘FuturaStd-Bold’, FuturaStd-Book, FuturaStd-BookOblique;

or

h3 {font-family: ‘FuturaStd-Bold’, FuturaStd-Book, FuturaStd-BookOblique;}

…all that happens is this appears as text at the top of my page :frowning: