How to remove redirect chain

I have been having redirect problems for a few months. Came across a website that analysed my home page today and it came up with the following under minimise redirects asking me to remove

Not sure where this would be. Have looked in the plugins and stacks folder.

Any help please,


Hi Richard,

Could you be a bit more specific on what problem you’re trying to resolve with redirects? Also what tool (website you came across) are you using?

The file you listed above appears to be the font awesome web fonts file used by some of your stacks. Fontawesome appears to be working okay on your site, and I’m not sure why this would get flagged as a redirect error.

Hi Doug,

@teefers The website was I understand reading what you said that I need these fonts.

I am clutching at straws trying to solve a too many redirects problem at It appears to be worse with Safari so I am using Chrome now to look at my own website. Although when using chrome sometimes you can see a redirection fault page for a tenth of a second before the page appears. Just trying now browser Brave has come up with redirected too many times

I have asked my hosting company Easyspace many times to help. There last reply was

There may be plugins that you have active that will be causing this. You would have to disable these in order for the redirect to go through normally.

If you enter my site by going in from another of the many pages the error does not happen but if you stray to the home page a number of times it will happen.


This sounds like an .htaccess issue to me. what is in your .htaccess file?
Are you using Cloudflare?
Are you setting Referrer-Policy in .htaccess?

@swilliam Thanks. I am not using CloudflareI wondered about the .htaccess file. It was written for me by Easyspace. It reads

#RewriteEngine On
#RewriteCond %{HTTPS} off
#RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

RewriteEngine On


ensure www.

RewriteCond %{HTTP_HOST} !^www. [NC]
RewriteRule ^ https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

ensure https

RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

ErrorDocument 404

This line is causing an error in Safari:
<meta name="referrer" content="same-origin" />

What is the reason you added this?
You may need to modify .htaccess file if you need above referrer for some reason

I also see a hiccup in the css for that page where a macro didn’t get translated into a css statement this probably happened during export/publish.

I would mark all pages as changed and then republish all files.

1 Like

@swilliam Thanks Scott. I will certainly do a mark an all pages and export. When you said this line is causing an error in Safari, which line did you mean. Sorry I am not into the code of .htaccess files

thats because my dumb self forgot to mark it as code - fixed

1 Like

@swilliam Export in progress, just another 2160 files to go. No idea about that line. But will delete it when I have control again and report back to you.

You may also consider this: “Too many redirects” error indicates that there is at least one bad link in your website.


Please, check the link in the report.

Thanks. Will take care of that. Think I have found the answer. All to do with the .htccess file written by my web provider.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.