Newbie...a click performs a download

Hi all,

I am totally new to RapidViewer and I downloaded the trial version.
I just created a project using the Future Template and published at S3.
When I click on the “left side bar” with “Blog” and “Gallery”, Safari tries to download the “blog” page inside of loading it. The same happens when trying locally.

Thanks
Marco

Not sure about how you have S3 setup, nad when you say “trying locally” what do you mean?

If you don’t have a Web Server like Apache or Nginx running, then that might be the problem.

When in RW right-click on the page and select “preview page with” and see if that still happens?

Ok my web server did not start properly; now I have a web server which is running on port 8080 (php -S localhost:8080); root dir is “/Users/Marco”; I published there (from RW) and loaded Safari with localhost:8080/website".
I have just an Home Page, a second page and “subpage”; I click on “subpage” and I get “/markdown/markdown-2/ - No such file or directory” but the file is actually there; I am investigating

Okay,
What web server are you using?
RW by default uses what they call tidy links. They rely on the web server (Apache is the most common) DirectoryIndex directive. That will look for files like index.html or index.php in the directory.

I am using “php -S localhost:8080”

Ok now I tried with MAMP, but if I hover on “blog”, on the status bar I see “file:///Users/marco/Sites/localhost/markdown” and if I click it opens the Finder showing me the file

That isn’t a full feature web server.
From the php manual:

Warning
This web server is designed to aid application development. It may also be useful for testing purposes or for application demonstrations that are run in controlled environments. It is not intended to be a full-featured web server. It should not be used on a public network.

Although it does do some stuff that a full server does, it won’t do things like tidy links. If you want to run a local server on a Mac have a look at MAMP. The free version works for most of what the average RW user would use.

You could also turn off tidy link in advanced settings and try it with the php server. I don’t use it so I don’t know what other issues you might hit.

Yes with MAMP it works fine; now brought it to S3 and removed tidy link, let’s see.

Thanks

How are you laucnhing MAMP.

I just tried the exact samething and the address doesn’t show as file:///. That looks like you are just opening the page with finder.

It should show as something like localhost:8888/blog/.

Ok now with local server works fine, but not on S3

I’m not an expert on Amazon S3 or Amazon Simple Storage Service, but my understanding about AWS is there are ways to configure it so you can use a web server( Apache, Nginx, etc, etc). Plain Amazon S3 provides the option to host static HTML website only.

Although you can produce plain static HTML with Rapidweaver you would have to work at it. If you can’t preview and navigate the site published locally without a web server (just with finder) then it probably wouldn’t work on S3.

1 Like