Paysnap and Stripe

Hi, is anybody else having trouble with Paysnap not connecting to stripe? I’m getting quite a few people now telling me the cart has issues and when you click pay with card it doesn’t seem to connect with stripe! So the transaction can’t continue as you can’t enter your card details!
Any ideas would really be appreciated! Could this be a stripe issue? In that it can’t connect!
Here’s a link if any of you could try and get to the card entry section!

Hi Kelly,

I have the same issue on webshops I created (with Cart3 and Paysnap). Found out that people using the MS Edge browser can have problems paying. I did not found a solution for this. It seems Edge is very rigorous when it comes to privacy settings. Even Amazon ran into paying problems with Edge.
I advise customers to try with a different browser, most of the times this seems to work.

Hans

1 Like

Hi Hans

Thanks for the reply. I’ll ask customers what browser they have the problem with. I know one of them was on an iPhone so I’m guessing that wouldn’t be Edge! It’s worrying as it’s always been fine with no complaints until recently and all I did was a few updates to other bits on the website!

Kelly

You really shouldn’t offer a solution that tells customers to “try a different browser” unless it’s a very outdated or obscure browser. How many customers have you lost because they’re using the latest browser offered by Microsoft? Especially when you tell them it’s because the browser is too secure.

Not to mention the majority of web customers aren’t going to go through the effort to contact you, they’ll just move on to your competition’s site, which has no problem taking their money.

In the desktop world (still over half of the shoppers are using desktops) I believe Edge is now the default browser for Windows.

I use Edge all the time on Amazon, and never had any problem.

Even if it was Edge it’s like every browser on iOS. You see Apple controls what can and can’t be put on iOS and iPadOS. And they only allow browsers that use the WebKit rendering engine.

So even Chrome (or any chromium-based browser) and Firefox on iOS or iPadOS isn’t the same as it is on other platforms. They’re probably going to behave closer to Safari(WebKit) than the way they work on Windows, macOS, Linux, or any other platform.

Now that I’m done with my browser support lecture, let’s move on to the next topic. :smiley:

Since you’ve said “quite a few people”, it sounds like you have identified a real problem.

Can you reproduce the problem yourself?

1 Like

Haha! thanks for the lecture!
I can actually reproduce the problem yes!
It all works fine on the imac and an iPad!
I can only get the problem to occur on a friends iPhone (which is using iOS 15.0.1) and using the google app! It just doesn’t connect to the card payment details bit! But on the Safari app it’s fine!
On my iPhone (which is using iOS 15.1.1) it works perfect on either the safari or google apps!
When I say a few, I’ve had four people emailing in the last week saying the card details won’t load!
Which is pretty weird!

Should I assume that when you say “google app” you are talking about Chrome? There’s a number of Google apps but since we are talking webpage my guess will be we are talking Chrome.

Unfortunately, iOS (and iPadOS) are extremely locked-down environments (thank you Apple). That makes debugging even simple web problems a real painful experience.

You can use some of the Desktop Safari tools if the iOS device is plugged into the Mac and you want to figure out a bunch of stuff to make it work, but that doesn’t help with non-Safari browsers like you’re having issues with.

So it’s much easier if the problem can be reproduced on a desktop, but that’s not happening at least not with the one that you can reproduce here.

The only debugging tool available from chrome inside the iOS is the console log. And even that’s a bit of a chore to get to but it is probably the only option you have available and it’s where I’d suggest you have a look.

To have a look at the log in Ch on iOS you’ll need to

  1. Open a second tab in Chrome
  2. In the new tab type the following address chrome://inspect
    You should see a screen that will be mostly blank but have a button that says Start Logging press that button
  3. Now switch back to the original tab, and go through the steps to recreate the problem it’s important to leave the logging tab open while creating the problem
  4. Once you’ve recreated the problem, switch over to the logging tab. Whatever is there will be what you are going to get. This is in memory only so you’ll need to capture what’s on the screen yourself. you can select it and copy it.

Hopefully, this will give a clue for you or the developer to see what’s happening.

More here on Chrome logs in iOS

1 Like

Works fine in Edge for Mac. Is this a Winblows issue?

Thanks @teefers i’ve just tried it… gone through all the steps but I don’t seem to get anywhere with it. On number 4 there’s nothing there for me to capture!

Definitely not just a windows issue! We can recreate the problem on iOS

Does it even happen on Windows?
If you can reproduce the failure on Windows, then unlike iOS and iPadOS you have a full set of developers tools available to debug.

You didn’t mention Edge either, you are seeing the issue on Chrome right?

One of people that contacted me to say it didn’t work did say they were using windows! I haven’t got a windows machine in the house so can’t really check what happens!
I can only recreate the issue on the iOS Chrome app and also the Google app but Safari works fine!
This is as far as it goes!! Those three dots just keep going and that’s it!

For what its worth, I tried on my windows comp and was able to add to the cart and proceed to the checkout screen (i.e. past your three dots screenshot). This is on Version 95 on Microsoft Edge.

Works on Firefox too. Our IT doesn’t allow Chrome to be downloaded, though, so can’t check there.

1 Like

I had this problem earlier this fall. Believing it to be a Stripe issue I contacted them and suffice to say, that wasn’t helpful. I ended up deleting then redeploying the entire site which fixed the problem. Guessing some files had gotten corrupted and RW isn’t always good about updating files when they need to be updated, in my experience anyway. Some may disagree with this solution but it worked for me.

3 Likes

I think you’re on the money there.

I had an issue with Paysnap and Stripe once. Every now and then it just wouldn’t connect. I eventually nailed it down to partial publishes when only a small part of that site was changed. Even if it wasn’t on the store page.

I worked out I needed to do a full republish, even when only making a minor change, to overcome the proplem.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.