Permalinnk is it a must

(Graham Smith) #10

This is also a puzzle as I back track through the settings on your Total CMS implementation part 3 The edit form page and post view page are non existent I have scoured all the options looking for this but too avail what am i doing wrong.
I have managed to get a feed post on my blog page but no images as yet.

Could it be that I have uploded the cms data to the wrong location, where exactly should I place it Please
Graham**strong text**

(Joe Workman) #11

Please watch this…

(Graham Smith) #12

Hi Joe done everthing you said but the all important preview is still throwing up error after preview

the light box is showing 160+ problems.
I have set the Pretty url l into the .htaccess filemy urls are all the same my host server has srt the redirectfor me I have gone no www. and the same problem persists If you could take a lookat my website it I have left the admin and blog post visible

(Joe Workman) #13

I am not sure what that lightbox error is coming from. That is not from Total CMS or any of my products. Maybe the theme?

(Joe Workman) #14

When I click on the blog post page in your site, there is an error at the top of the page. Did you read the FAQ that this error links to?

(Graham Smith) #15

JoeI have read them and read them and red them yes the last one was red because that is how i feel blood red mad, frustrated, confused and completely nonplused , what is so complicated . I have followed your guide lines I think to the Letter but there is obviously a gremlin,devil call it what you will that is bent on stoping me from doing this

(Graham Smith) #16

There is no theme only foundation I am getting realy frustrated this is taking up too much of my time, very tempted to ditch this and go for word press which on a free account worked perfectly, However as a foundation fan I dont want to go down that route I simply just want it to work!
how big an ask is that?
As a guy who knows his way around the web Perhaps you could sort this out on a one to one basis

Here is a screen shot of the blog post page that shows it can find the file in Preview Mode but just returns error when submitted


(Graham Smith) #17

Jo jo was man who thought he was a loner remember the beatles hey Jo
Well hey Jo you are ignoring me its not nice
Then there is the great Jimi Hendrix and hey Joe.
All i want to do is get a blog going, my host set me up with word Press for free but I didn’t like it I paid £100 smackers for this but your most important page aint working I have deleted all the files and started from scratch my host has redirected both my main site and my sub domain to https, no www
and whilst i can publish edit my files on line the post-permalink still shows error and guess what NOTHING IS SET. help me or refund that’s all I can say. Talk about Godaddy what’s going on here.

Just so you know I am on a 27 inch Mac just bought and I am a rapid weaver fan well almost was Some of you guys Nick cates included Don’t want to go the extra mile. I am trying to be nice but after day after day trying to sort what should be simple , my wife wants a divorce you know what I-am saying In my business if something is wrong I fix it

(scott williams) #18

You need to very carefully watch the video joe posted above.
It’s not difficult but you can not miss a few steps.

  1. Your url setting in RW must exactly match your true url
  2. You MUST preview the blog post page and hit the green send button when the modal windows appears. That sets the paths in the blog.

There is not a problem with TotalCMS hundreds(thousands?) of people use it, you just need to follow the steps.

(Joe Workman) #19

I am not ignoring you. My kids needed a father this weekend. There was no time for work. Hopefully you understand that. I am about to take my kids to school right now. I will review what you have sent here and try to get back to you today.

Sorry that your wife wants a divorce.

(Graham Smith) #20

Thank You Scott and Jo For getting back to me, I too am back to work so now have less time to work on this, What seems very simple on the video doesn’t seem to work for me. If my understanding is correct a lightbox usually comes up with a black background , it doesn’t for me it pops up with looking like this and when Submit is pressed it returns error

My web hosting guys have set up redirects to https.
and I have used the exact urls given to me son Non plussed

(scott williams) #21

I’m sure Joe will chime in here, but if it was me this is what I would do (not knowing what error you are actually seeing):

go back to the defaults and get it working that way first

  1. check the url you have set in RW for the project
  2. get rid of any pretty url code in your .htaccess file.
  3. preview the blog post page and click the default url button
  4. when the modal pops up (mine is white also) does the URL look correct? Click the send
  5. go to admin and edit a post (just add a space at the end of a line) and save it.

Once you get it working on default url’s, then tackle the pretty url settings.

FYI, if you hover over the newspaper icon in the ADMIN blog list page and click the small link icon, it will show you the permalink url. Is it correct?

EDIT: I can see the issue is that there is no postURL being saved - that happens when you hit send in the modal window of the post page in RW preview. That is the basic issue. What is the error message when you hit send?

EDIT 2: here is where the first one actually is: This tells me that your Public blog List page and Your public Blog Post page are in the same folder (/blog). I know joe showed this in the video, I’m not sure why. I would make the post page a child page of the list page and change the name back to index.php unless you have some reason not to.

(Joe Workman) #22

As I said in my video, you should always try to get the blog working without pretty urls first. I am not sure that you are following the video step by step.

However, there definitely is an issue with saving the blog post URL on your server. I see that you are using a Windows server. While there are a few customers running Total CMS on windows, I am not surprised that there are issues. Apache on Windows has historically been very buggy and glitchy. I have found one minor glitch that I can get fixed in an update later today. However, there are others that would take me some time to debug and figure out.

Does your host give you an option whether you get windows vs linux server? If you can switch to linux, I would strongly recommend it as it will save you a lot of headaches over time.

If that is not an option, please email with your FTP credentials to the server. I will try my best to get things fixed up for you.

(Graham Smith) #23

Many thanks Jo will do this evening I think they only use windows

(Graham Smith) #24

How would I make it a child

/blog/blog is this how

many thanks Graham Joe has got it working to a degree, but still doesn’t post without error it doesn’t say what the error is

regarding the link these are what are showing
post Blank
rss feed //
site map //

as a completely separate question can horizon be used in the admin pages of the blog please

(Graham Smith) #25

Many Thanks Joe it seems to be fixed, but not sure if it is sending all the useful stuff to improve SEO ratings.
Also the blog post still doesn’t post without an error.I have said a big thank you on my Blog to you. you mentioned that there were quite a few glitches due to windows hosting, that you would endeavour to iron out.

Does horizon work in the admin section of the blog and what size image should be used, it seems to make the images too big so I haven’t tried posting yet

(Joe Workman) #26

Oh great! You got everything working!

Not sure how you would use Horizon in the admin area. I would just stick to the Total CMS admin stacks.

(Graham Smith) #27

Ok Joe many thanks for your help, another problem has just arisen in that images are being saved but it isn’t saving the text, and the permalink blog post pace still returns error on publishing

(Graham Smith) #28

Solved One Problem I had recapcha added at the bottom but not formatted,
So just the permalink publishing returning error

(system) #29

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.