RapidWeaver 8.1 is live!


(jim rosebrook) #21

Updated to this release version and republished a site from scratch after deleting all files at hosting service. Resources are not all uploading as they should. No link problems indicated… all appears to publish just fine. Some of the files simply do not get put in resources folder at hosting service. All worked fine with 8.03

UPDATE: Solved my problem myself… I needed to remove spaces from my resource names and republish. All works fine now…

Lesson to be learned: The name of a file that is fine for macOS might not be fine as the name of a file to be uploaded as resource. Earlier versions of RapidWeaver 8 would automatically replace spaces in a file name with hyphens so all would upload fine. RapidWeaver 8.1 does not automatically put these hyphens in for you. Nor does it let you know there’s something wrong in trying to publish this resource that has an improper name.


(Shubhanyu Jain) #22

@dan you might want to look into this and helping us users with regards to this in a future update. Let’s have hyphens or underscores instead of spaces, or a clear warning about the issue arising out of spaces in resource file names. :slight_smile:


(Frank Land) #24

@dan Under RW 8.1 RW forgets the assignment of the resource. For example, in the Slate Theme of Nick Cates, the banner images are assigned via Resource (banner1, etc.) If you open the project, the Resource images are not displayed, they are visible only when they are re-linked. Unfortunately, RW does not save this and the next time the project is opened, the banners are not assigned again!


(Joe Workman) #25

I wonder if granting RapidWeaver full disk access will help solve the issue?


(Joe Workman) #26

I am also curious if the Site Resources setting in the project is set to Copy in Document.

19


(Tom Bradley) #27

@joeworkman Please don’t allow full access to RapidWeaver, we have a fix coming (most likely tomorrow) that will alleviate the resource access problems. The problem isn’t completely solved - we’re waiting on Apple for that.

Copying resources into a document will definitely work, the problem only occurs when referencing resources outside of the document. All new documents are set to copy by default.


Rapid weaver Version 8.1 (20579)
Updated RW8 and cannot save document
8.1 > "This document uses files in multiple locations that Rapidweaver is unable to access"
(Chris Jones) #28

Dan,

After upgrading to RW-8.1, I too am having this Problem: “This document uses files in multiple locations that Rapidweaver is unable to access” …

  • I keep my project files in Dropbox to be able to update my websites at home or on the road…

Everything went fine on MBP but when I tried to open the project files that are in Dropbox (After opening them on my MBP) on my 27" iMac I got the “multiple file location’s” pop-up’s. This only happened on one of my project files. The IMPORTANT one… I now get the pop-up on both Macs…

I am not in a rush… Should I stay on 8.1 and wait for fix… Or go back to RW 8.0.3?

**I have included the problem project file for “JONES X-RAY INC” in a email to you

Thanks for you incredible work!


(Tim Proctor) #29

Downloaded and installed 8.1 today and looks like it’s not ready for me, windows flashing, some options not working. Downloaded back to 8.0 as advised but now get error saying 8.0.3 can’t open the project that 8.1 was opened in.
Not real happy right now.
Using imac running 10.12.6

Solution?

Thanks, otherwise have always loved RW.


(Tim Proctor) #30

Now it would appear that every project that touched 8.1 won’t open in 8.0.3. Really messing things up here.
Knew I should have waited longer.


(Doug Bennett) #31

Not sure what exactly you are talking about, what windows are flashing? What options aren’t working?
I’ve been using the 8.1 beta since it’s first release, and can’t remember any “flashing windows”. Also haven’t seen any options that didn’t work.

If you’re here to get help then be specific, perhaps a screenshot of the window that flashes or tell us what exact option you found that doesn’t work for you.


(Markus Frieauff ) #32

I don’t think this behavior is a bug. Sounds more like serious issues in the OS or like an incomplete installation. Try reinstalling 8.1 (by de-installing it and redownloading it).


(Olaf Brandmeyer) #33

I have the same Problem with RW 8.1 is unable to get access to some resources. As far as I figured out – RW is now searching for some files that was linked via the „downloads-plugin“ a long time ago and witch were stored on an external drive witch does not exist any more … therefore I could not gain access to the drive :smiley:
I tried to alter the path manually in the project-file, tried to delete the Page witch referes to that files – but the messages shows up on every start oft the File. Maybe there are some other dead links stored in the RW.8 container?
The Project where that ocures is very old … maybe updated from RW 4 ore 5 to 6 and 7 and all the way up to RW 8 …
Not a dealbraker for me, because I want to make that site all new in the future – but I’m running some dozen sites and this will happen in other Files again …


(Tom Bradley) #34

@Olaf_B That’s a super old project! I’d love to do some testing on it, would you be able to send it to support@realmacsoftware.com?


(Olaf Brandmeyer) #35

Sure. I’ll send you two versions of it with additional Informations.


(Brian Kay) #36

Hi Dan and RW community. I’ve been an RW user since version 3 and now have version 6.
What are the major differences between version 6 and version 8.1? Just a quick list if you please.

What I’ve been looking for is something good for my web version ‘paper publication’ website. So showing off my advertisers in a kind of slide show or just on the side. Something that also works on a phone screen. If there is such away. Simplicity is the key. No floating backgrounds needed etc.

Perhaps I’m in the wrong thread here. Please point the way.


(Nick Wilcox-Brown) #37

@timpro Apologies, but this needs to be said before others do it too:

Backup before updating software
(or at least duplicate critical project files and try the copies first). I also had issues, but tried it on a couple of duplicated projects before going back to 8.0.3

Hope you managed to get things sorted OK?


(Tim Proctor) #38

That’s what I’ve always done in the past and for some reason, was so convinced it was a simple update, I jumped right in. Out of 7 ongoing projects only 2 were affected and one of those created just for testing these things so the issue, though disappointing, isn’t super critical. I’ll work with both versions as things are sorted out.

Your reminder to duplicate before jumping in is well taken and obviously was need on my part. Thanks!
Tim


(Mike Freeman) #39

Greetings, I was just prompted to update to the latest version of RapidWeaver (8.1.1). After doing so nothing works! It says it can not find about 40 files on an external drive and that my banner image is “not valid”. I have a lot of files and variations of files so it’s difficult to figure out where they all are at this point.

The previous version (8.0.3 ?) had no problem with any of this. What should I do?


(Gary Wann) #40

How about a screenshot of the missing files screen? The file names are shown so it should be easy enough for you to relink them and then make sure you haver the RW Advanced setting Site Resource ‘Copy into Document’ selected so that the files are saved with the project rather than being left on your external drive?


(Doug Bennett) #41

As Gary said you will need to figure this out.
It’s always best to organize your files, and know what goes where.

If you can’t figure things out, you could go back to 8.03, restore your project file from TimeMachine to a version prior to upgrading to 8.1. Then under advanced settings select “make document portable”. This is the old name (pre 8.1) for “Copy into Document”.