RapidWeaver 8.4 Beta 1

Hi @isaiah
I sent in a ticket about it and what seemed to trigger it, I can send in project files too if you can let me know where to send them too

Thanks for the info Paul, however I don’t think what you’re experiencing is the same as the crash that was posted above. Unless your issue crashes and you just didn’t mention that in the ticket. But thanks for the details. :slight_smile:

Well, to be fair, I guess there are a number issues being discussed intertwined here:

  • something about permissions – although i’m not sure if that’s an issue so much as a strange circumstance that’s best corrected just by fixing the permissions.
  • a “nil object exception” – which is a crash, but without any other details as far as i can tell.
  • a crash with a crash report that is presumably different than either the permissions thing or the nil object exception – the crash report seems to come after undoing, i think in stacks, but undoing what is left as an exercise to the debugger.
  • and a stuck stacks loading window.

i suspect that all the issues here are stacks issues. each of a different sort – but none with enough detail to locate the issue.

if anyone has any more info on ways to see these problems, please let me know.

moderators: if you’d like to split these off into a separate thread that would make sense as none of these things has anything to do with the RW beta release. thx

Yes, some issues are related to RW and some to Stacks 4. Doing undo a couple of times for Stacks related edits crashes RW every time.

Unfortunately my RW 8.4 Beta 1 won’t launch at all on the latest Catalina Beta. It bounces in the dock briefly but that’s all. Any suggestions would be greatly appreciated. I have stacks 3 installed too

Could you provide a tiny bit more detail. I’m afraid I don’t see this – and there’s some key ingredient that I must be missing. If anyone has a bit more detail – about any of these things – that would be awesome.

But, I think that’s my last post to this thread. If you got details, forward 'em and I’ll fix the bugs. If not… that’s cools with me too. :smiley:


I made a video. The best I can way is hiding/showing stacks and editing html.

Next up is the problem where I can make a stack vanish by doing a drag-and-drop.

Is there a release date for 8.4 yet?

It should be around the time macOS Catalina is released. We’re not sure on the exact date yet, but it should be sometime this month.

Many Thanks

I just got prompted by Mac OS to install Catalina which is why I asked. So they are already rolling it out.

Typical Apple.

Use the beta for now, we’ll have an official release out later this week!

1 Like

I have RW 8.3 from the AppStore. So I can’t register my Beta 8.4 and 8.3 does not work. How do I register the beta so I get full functionality, and how soon will the AppStore have the full 8.4?

Thanks in advance…

RapidWeaver 8.4 should be available via the App Store in the next few days (all being well with approval).


1 Like

And the Setapp version has already been updated. :+1:

I installed the V8.4 from the APPstore and FTP uploads still don’t work in 10.15.
I get an error login info is incorrect, but I know login/PW is fine as it works with other apps like Fetch.

Sounds like you were having issues prior to 8.4 “still don’t work”?

If so it would be best to post about the problem you are having on a separate new post. Most folks using RW aren’t experiencing any problems publishing. If you were having problems publishing with the prior release, than updating probably won’t fix it.

Create a new post here on the forum, give details like screenshots of the RW publishing settings and the error you’re getting. Also include the name of the hosting company and someone here probably can get things working.

1 Like

I had no problems at all with RW 8.3 in 10.14.

When 10.15 come out RW stopped working so I downloaded the Beta and it worked once for an upload, but I have the AppStore version, so when I updated to the Store version 8.4 uploads stopped again.

I know my settings are fine I use them in Fetch, below are screen shots of error report and my Publish settings.

Similar issue here, version 8.4 release. FTP signing fail, Inmotion Hosting

Update… problem must have been at Inmotion hosting. tried several hours later and all ok.

For some reason I had to change the Server line to ftp.xxx.xxx.xx.xx, and now it seems to work.
I will test more later. Apparently OS 10.15 has changed how it communicates with ftp servers.

If you’re having problems publishing, it’s probably best to try the test button. If you get any errors with the test it’s usually something wrong with the basic credentials (server, username and password).
If the test works but publishing fails then look at the path next. Best way to address this is to clear out the path and choose Browse. Then just select the directory (folder) you need. RapidWeaver will fill in the correct path for you with any / needed.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.