RW stucks while exporting site


(Theo de la Ruelle) #1

Sometimes when I export my website, the exporting stucks at the last page. The pop up Exporting doesn’t disappear, but the Cancel button doesn’t work either.
In that case there is only one option and that is to force stop RW. And then every change I’ve made in my website is gone. Even if I have exported single pages before.
It isn’t every time I export my website. But I haven’t a clue while this isn’t working.


(Brad Halstead) #2

@Theo

What version of RW?

What version of OSX?

Have you tried reducing the number of concurrent connections in the preferences?

Did you not get prompted to save the project prior to publishing?

Have you checked your server to see if there are active connections to it and cleared them?

Places to start anyway

Brad


(Theo de la Ruelle) #3

What version of RW? 6.3.7

What version of OSX? 10.11.2
Doesn’t matter, I have this problem since I use Rapidweaver, no matter what version of OSX or RW.

Have you tried reducing the number of concurrent connections in the preferences?
I don’t understand what you mean with this.

Did you not get prompted to save the project prior to publishing?
Yes, but that doesn’t matter. Saving is not the same as exporting. So when I open my project again, the changes are gone.

Have you checked your server to see if there are active connections to it and cleared them?
I don’t understand what you mean with this.

Places to start anyway


(Brad Halstead) #4

@Theo

The more info you can provide, the better the response. You can always contact support@realmacsoftware.com

HTH
Brad


(Theo de la Ruelle) #5

I don’t know what host I use. In my opinion, exporting has nothing to do with the host. Even when I don’t have contact with the internet, I should export my website. I don’t have problems with publishing the site, only with exporting.

So if there should not be a problem when I only save the project, why should I have to export the project every time? And why does RW starts with exporting when I want to publish the site? Why not only saving?

It is sad that the old forum don’t exist anymore. There I could find some Dutch users and it was easier to communicate in Dutch.


(Brad Halstead) #6

@Theo

Ahhh Translation issues, gotcha…

  1. Publishing is no issue

  2. Exporting site is an issue

1a. When the site is published to the internet it is exported first (I believe) to a temporary folder prior to upload and cleared after upload, this is to convert files and create folder structures required on the server from the project file.

2a. When manually exporting the site to a export folder, the export folder should be emptied prior to export or site styles and theme related materials may get confused (THIS is NOT the same temp folder used on Publish).

2b. When saving your project, RW does not automatically export it to the export folder on save, you must do this manually each time you want to test your site locally after any changes are made.

Does that help clear it up?
Brad


(Theo de la Ruelle) #7

So if I understand you right, I don’t have to export my site manually other than when I want to test my site locally?

I won’t do that again.

But the problem also sometimes appears when RW exports the site before publishing it.

The export folder, is that the actual folder where I see all the site-pages as subfolders? I thought this is where RW stores all the pages and pictures.

What is the .rw6 file? I thought that was the exportfolder.


(Robert Ziebol 🖖🏼) #8

The .rw6 file is same thing as a .docx file for word. It is where you save your work. Exporting it means you are exporting it to be put on a server, so it is changing what RapidWeaver looks like in edit and preview to what it should be on a web server.
Hope that makes sense.


(Brad Halstead) #9

@Theo

You understand me right, you do not need to export manually prior to publish. This is only required for 2 circumstances.

  1. You want to upload manually or
  2. You want to preview it on your local machine either directly or through MAMP or iServer or another locally installed server.

The .rw6 file is the project file, it contains everything your website is, aliases to images and other assets in your resources folder (in the project) and all data associated with your website. RW uses this project and, for a lack of a better term, creates your website from this file. It is a 1 document file and does not contain folders per se. Just to add to @zeebe’s feedback…

I hope you have not being exporting your site locally to the same folder as your project file, this is not the correct method imho, you should create a separate folder on your HDD somewhere (I use Desktop/Website) and on manual export, point it there and then you can view your entire site layout there including all files, folders, assets (that are local and not external links such as youtube or external references to jQuery).

As for having an issue on export occasionally during publishing, that is odd behaviour to me that it would be random like that. For me, should I encounter an error like that a simple reboot of my machine usually fixes any hiccups that may be occurring in any app on my machine. But, I am a beta tester of many things so random issues for me are common :wink:

I would suggest that when this happens, zip the project file, send it to support@realmacsoftware.com with a detailed explanation. You may also manually generate RW logs and include those as zip files as well. They can be generated from RapidWeaver -> Help -> Copy Support Logs and paste them into a txt file and send it with the project file.

I hope that clarifies it for you.
Brad


(Theo de la Ruelle) #10

Thanks for your answers. Now it is a bit more clear to me. I won’t export manually anymore and hope it is over now.

And otherwise, if the problems continue, I will come back again.

Merry Christmas and a happy and healthy 2016.

Theo


(Patrick) #11

I have the same issues, i don’t understand why. I use RW7.0.4 under El Capitain and OS X Sierra.
Even with a new project, i keep getting the export failing 2 out of r times. Cancel a export is not helping, because RW cancels but when i try to do it again i get the error there is already a export going.

It always stuck in exporting the site, that is before the actuele copying to the folder.