RW6 website "container" fell apart


(Ed Foskey) #1

My .RW6 file for my web site has come completely apart! By that, I mean to say, that all the files are on my hard drive are not in the “container” but are in folders and subfolders, etc.

Unless there is some sort of “fix”, then I will have to rebuild my web site from nothing! ARRRRGGGGHHHH!


(Mark Sealey) #2

@edfoskey,

We’ll possibly be able to help: please explain a little further!


(Ed Foskey) #3

I am not sure how to explain further. You can ask questions that I will gladly try to answer. The best way I know to describe it is this. Where my WEBSITE.rw6 “container” was located is now a folder named untitled file. The contents of that folder look like this screen shot:.

I hope this helps you understand what I am trying to communicate. If it is possible to restore this to its original form, that would be amazing and save me probably a few hours of time at the keyboard.


(Doug Bennett) #4

This looks like you did an export site from the file menu. An export should not harm the rw6 project file. Have you tried to go to finder and do a search on the name like WEBSITE.rw6?


(Ed Foskey) #5

Teefers,

I did a search for the the name and came up empty. I don’t remember doing an export site, but it has been a while since I was even in RapidWeaver.

-ed-


(Mark Sealey) #6

@edfoskey, let’s assume that you did indeed Export your RW 6 site, as Doug suggests.

That means that RW took the pages’ content from your project and ‘published’ it locally. Usually, in versions prior to 7, this has been so that you can see what your site will look like (e.g. by dragging the top level index.html (etc) file to Safari on your local machine).

It doesn’t affect your Project File (what you refer to as ‘Container’).

One way to find that RW 6 Project file would be by launching RW and having it ask you if you want to resume working on an existing Project. It’s likely that one of the Project files which this dialogue offers you will be your ‘missing’ Project.

Good luck!


(Ed Foskey) #7

Thank you MarkSealey for the suggestion. Unfortunately, RW 6 (where I created the project) does not find any previous project files (I only had the one file).

I do have a help request into realmac software and have received an initial response seeking additional info.

I will post here how the problem is resolved.

-ed-


(Mark Sealey) #8

Good luck, @edfoskey!

If - as we suspect - your original RW project file is… somewhere, you should be able to find it simply by navigating to your ‘Sites’ directory, or to wherever you usually keep your web projects. That’s where it’ll be.


(Brian LaPan) #9

Have you tried searching your hard drive for .rw6 files? That might make is show up.

Sometimes (very rarely) a sitefile may have it’s extension removed by OSX. Try appending .rw6 (if Rapidweaver 6) to the end of the file name (Untitled in this case) and give that a try. You can always remove it if that’s not the case.