RW8.2.1 + Ecwid plugin - "please enable Javascript"


(Fiona P) #1

This seems to be a common problem with the Ecwid plugin, but I haven’t seen anyone mention the Javascript message I’m getting.

MacOS High Sierra.
RapidWeaver 8.2.1
Most recent Ecwid plugin, literally just re-downloaded and re-installed.

When I try to connect my recently-created store, I get a popup saying “This website requires JavaScript in your browser. Please, turn JavaScript on.” (see screenshot).

I have no idea which browser needs Javascript. I assume the built-in RW browser. I have gone into all three of the browsers I use (Chrome, Firefox, and Safari) and ensured their Javascript status.

I am able to right-click on the popup page and “inspect element”, and have downloaded the .webarchive file thus generated. (I think). (Which I can’t attach here, but this is the error it’s displaying:

).

However, doing so makes the popup very cross, and I have to close RW to get rid of the “shadow”.

I’ve downloaded and installed the plugin twice. I’m not uninstalling and re-installing RW just to get this working. I’ve removed and re-added the page.

The demo page is displaying fine. I just can’t switch to my own store.

I’ll try pasting in the generated code, but I would - of course - prefer to use a nice plugin …


Re-connecting to an old Ecwid store
Re-connecting to an old Ecwid store
(Matt Kuritsyn) #2

Hi Fiona,

Thanks for reporting it and thanks for all the details. It seems like it’s related to Re-connecting to an old Ecwid store

We’re looking into it. I will provide updates in this thread as soon as I get them.

Thanks,


(Fiona P) #3

Thanks!

In the meantime, I’ve got a perfectly serviceable shopping page setup with Stacks and HTML, with the Ecwid code snippets; now I have a reasonable handle on how it works, I’ll import my products and see how it looks. I might even be able to go live by the end of the weekend!

I was delighted to find I didn’t have to upgrade to the most expensive option to use my Square payments, too! I thought I’d have to! I know it won’t integrate with my inventory but I don’t actually use it that way yet anyway, so no great loss. It was the payment gateway I wanted, so I’m extremely pleased.


(Matt Kuritsyn) #4

Fiona,

We found the reason of the issue. It’s fixed now. Please download the latest version of the Ecwid plugin — it should work fine now.


(Jan Fuellemann) #5

I do not use Ecwid but I think your customer support is great! :slight_smile:


(Fiona P) #6

It does, indeed, work now! Thank you so much for your prompt response!

… mind you, the HTML+Stacks works pretty nicely as well but hey, at least I have the option of the plugin :slight_smile: