Santa not responsive


(Ed Westerik) #1

Theme “Rainbow” by Henk Vrieselaar functioned perfectly responsive for years
in preview mode and in all browsers.
After changing frontpage photo (I tried several) it is responsive in preview mode,
but NOT anymore after being published!
Is there a RW wizard in the house who can help me out?

Ed


(David) #2

A url is really needed to help with this. Have you tried republishing all files?


(Ed Westerik) #3

Thank you for the quick answer.
Here is the url http://www.bedlingtonterrierclub.nl
Yes i did try “republish all files”


(Ed Westerik) #4

Sorry,…it is not the "stripped " theme but the “Rainbow” theme by Henk Vrieselaar.
The problem is the same though…


(Rob Beattie) #5

Henk used to have comprehensive docs for his themes which I can’t find on the new dev’s site. I think I remember an option or snippet in there to make images responsive. I’ve had a quick look at the demo on http://www.themeflood.com and can’t see a page there with a banner/background image.

Perhaps @willwood can advise?


(Will Woodgate) #6

Old documentation links, Collage packs and code snippets: https://themeflood.com/henks-themes/


(Rob Beattie) #7

Maybe this is the answer?

https://themeflood.com/knowledgebase/henks-manuals/manual_rainbow/index.html#Fluid%20images%20with%20the%20flexible%20tag


(Kunstmaler) #8

In some (old) themes from Henk you must write in the image Alt Tag: flexible


(Ed Westerik) #9

The very comprehensive manuals from Henk are part of the theme, so i do have all the snippets and i did use the Alt Tag: flexible.
I was in contact with Henk about this problem and he gave me several tips and
CSS code but we could not solve the problem.
Preview mode shows perfectly responsive, but after publishing it is not responsive anymore in the internet browser.


(scott williams) #10

After adding the css did you republish all files from the file menu?


(Ed Westerik) #11

Thank you Scott,
Yes i did republish all the files.


(Ed Westerik) #12

Hello Will,

Thank you for your answer.
The theme IS responsive in preview mode (for all browsers)
After being published the site is not responsive.
So i think the problem is maybe NOT in the theme but in the “transition”
(publishing stage) to the server.
Does that make sense to you?


(Don H) #13

Ed, I’m not sure where it’s coming from, but the container DIV is being set to a width of 1200px. Everything inside of it isn’t responsive because of it.

Try this in the CSS section of that page:

div#container {
width:100%;
max-width:1200px;
}

Depending on where it falls in the consolidated CSS file, you may need to use !important on the width.


(Ed Westerik) #14

Don,

One big step forward!! :slight_smile: !! Thank you for that.
The picture (frontpage) is ok now.
The menu and the other pages are not.
I pasted your code on every page.!


(Don H) #15

I’m not seeing the code on all the pages. I only see it on the home page. Did you republish all pages?

It also looks like most of the other pages are set to an 850px width. For those pages, I would change the max-width to 850px.

You could put the CSS code in the site-wide settings with a max-width of 850px and then put it in the home page’s CSS with max of 1200px to override the site-wide max.

I’d also rename all of your folders instead of using the default that RW assigned. “styled-7” isn’t very descriptive. I would name the folder “links” instead of “styled-15”.


(Peter Danckwerts) #16

I find santa unresponsive too. I asked him for £100,000,000.00 last year and he has failed to come up with the goods or even reply. :grinning:


(system) #17

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.