Setting to define PHP installation

Big Sur officially deprecating CLI tools…

WARNING: PHP is not recommended\nPHP is included in macOS for compatibility with legacy software.\nFuture versions of macOS will not include PHP.
PHP 7.3.22-(to be removed in future macOS) (cli) (built: Oct 30 2020 00:19:11) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.22, Copyright (c) 1998-2018 Zend Technologies

I would really really really love to see the ability for users to define a PHP installation path for what version of PHP is used in preview. This would really help future proof things.

It would also allow me to test with the same PHP version that could be running on my server.

I was really hoping that Big Sur would at least update to PHP 7.4 since I plan on requiring this version starting next year in some of my products. Sadly this really hinders my ability to do so. A setting that lest the user define their PHP installation path could solve this.

@tpbradley @dan Maybe something that could be added to RW9?

I’ll add it to the todo list for RW9.

Cheers
Dan

1 Like