Stackapps stopped working and Setup Stack causing long page loads


(Daniel Manchester) #1

The website (web app) was working perfectly and after I published an update every page with the Setup Stack would take over a minute to load and any content in a stackapp stack wouldn’t be displayed.

As far as I was aware I hadn’t touched any of the details, but noticed that the ‘login page’ link had changed to another page?? I changed this back and double checked that all the other information was correct.

To isolate the problem I have archived the original RW file on my HDD and published a stripped down version of the website (web app) with only the setup stack on the login page.

Main Page with no setup stack

I have published the page with security and without (security was enable when it was working) and this didn’t work.

I also added a setup stack to another website (separate Rapidweaver file) same setup info and again this caused the page to take forever to load and the stack app content not to display.

I have deleted and reinstalled the stackapps package and noticed the global setup info was still there, can this be reset and would that help?

I have installed the latest RW updates but haven’t upgraded to Stacks 3 yet.

Any help or ideas would be greatly appreciated


(Daniel Manchester) #2

An update:

I resolved the issue and like most, it was a simple one. the database info was changed due to having two different stackapp setup files open at the same time… like everyone says you shouldn’t do.

What I didn’t realise when I checking the info is that I overlooked the localhost naming, it was changed from localhost:3306 to 127.0.0.1.

live and learn.


(rob) #3

Hi Artisan,

I have the same issue and i’m following your path, but no result so far…

indeed the localhost in the DNS string has changed automatically to 127.0.0.1. i changed it back but still the same error when the session is gone.

first it seems like forever that the page loads, and then i get an error message like …Stack apps could’t find the login page… make sure that…

the issue is that i have 1 main page. and 3 sites that are beneath them (in a submap) a user logged in through the main page and get then redirected to one of the subpages. everything worked fine for a while i think… but now everyone gets errors.

is i due the fact that the cookies are on all sites the same (so users can switch through sites with the same password)?

do you have any suggestion, it’s driving me mad.

thanks,

Rob


(rob) #4

StacksApp Code Generation Error: Can not access Login page ‘http://www.mboondernemer.nl/test_omgeving/’ in Setup Stack. Make sure it is defined either with the Setup or the Security Stack. Don’t use external URLs to link to the login page.
Please check the manual for further details …