Can one use warehouse images in CMS Gallery?


(Timothy J Freeman) #1

Ok I have been trying to upload images to one of my pages. I was trying to do it through warehouse images. I was trying to do it through CMS but when I drag the warehouse image stack into the CMS gallery it doesn’t work. Perhaps I should abandon using CMS gallery and just upload separate images? But then I still don’t see how Warehouse image works. I don’t know how to find the Image URL. I uploaded a gallery of images to the server ((Chillidog). I optimized all the images through ImageOptim before uploading to the server. I uploaded the gallery of images to a subfolder under the public_html folder. But I don’t see how to find the Image URL. I am about to abandon trying to use warehouse images because it is just taking too much time to figure out. I can just upload images directly from my desktop folder to the CMS Gallery, but I’m guessing that is not recommended.

I could not find a tutorial on using warehouse images in CMS


(scott williams) #2

What CMS?


(Timothy J Freeman) #3

I have total CMS.
Is the Warehouse Image stack incompatible with Total CMS?
I imported the Gallery Stack, both the Admin and the Content, and then tried to use Warehouse Image. It seems not to work and thus I would just import directly from my desktop folder the images one by one without using Warehouse?

I am so frustrated I cannot think straight after working all day on this.

And I so regret upgrading to RapidWeaver 8.
I was just getting comfortable with 7 and now 8 crashes every time I tried to add another resource.
So I tried reopening my project in 7 and now it won’t publish.
And now I am totally screwed for tomorrow’s classes which I teach at a university and now I cannot upload the material covered for this week.


(Jannis from inStacks Software) #4

AFAIK, the Total CMS Gallery only supports image uploads from the admin stack. Which is a good thing, because it keeps things easy and consistent.

Having (in RW) predefined warehoused images in a (dynamic and online controlled) Total CMS Gallery does not make sense to me really.


(Timothy J Freeman) #5

OK Thanks very much.
I kept hearing about the importance of using warehouse images to save space. So I guess what you are saying is that warehouse imaging is not necessary in Total CMS because having the images uploaded through the Admin page is sort of the same thing?

So I abandoned trying to use Warehouse Images and using Total CMS for adding a photo gallery to my site and instead just added a photo album page. Is that a good idea or does that use more space?

https://pactphilosophy.org/PACT2019/photos/


(Jannis from inStacks Software) #6

More or yes: correct.

You have definitely more flexibility with Total CMS Gallery. Now you have to open RW again and again when wanting to change an image.

It does use more space inside your RW project file, yes.


(scott williams) #7

Jannis is correct, Tcms takes care of the data storage, no need to warehouse, Tcms is doing that for you.

FYI - You can select and drag multiple image files to the drop zone all at once.


(Timothy J Freeman) #8

I don’t know what I am doing wrong with Total CMS Gallery. I imported the proper stacks in Admin and Content, double checked that I used the same CMS ID. Republished all files to the server. And every time I try to drop an image into the Gallery Admin page preview mode I get a message back “server responded with 0 code.” I double check that I am connected to the server. Repeat and double check all the steps. Still no luck. Been trying to figure this out for hours and hours and nothing works.


(Timothy J Freeman) #9

Also RapidWeaver 8 has crashed on me several times through the process. Why oh why did I buy 8 when 7 was working just fine? Every time I reopen RapidWeaver 8 I have to re-enter the password for the server in publishing setup.


(Timothy J Freeman) #10

So far I am very unhappy with RapidWeaver 8.


(scott williams) #11

Put the CMS debug stack on the admin page and preview in RW, that will tell you what’s going on


(Robert Ziebol 🖖🏼) #12

If what @swilliam tells you to do does not work, email Weaver’s Space at support@weavers.space


(Jason Bostick) #13

If you try deleting and re-saving the bookmark for that publishing setup, that might fix the issue