Changing site to https and all asset images are loaded over http


(Dominick Designs Websites & Tech Training Seminars LLC) #1

I just changed http to https on this site

and now when we go to https://beaufortconstruction.net/testimonials/ the images that I dragged into one stack (there is no option for warehousing in this particular stack) are all showing an error in the browser console that the image is served over https but requested http.

is there a way to get around this error? Or do I need to drag each image into the stack again in order for it to load over https?


(Paul Dennison) #2

All looks fine to me, also checked it with whynopadlock and had no warnings for mixed content.


(Peter Danckwerts) #3

Chrome says that the connection is not fully secure because of the pictures. Did you change the web address to https in the Settings/General tab? This should automatically change the image links when you republish.


(Anonymous Coward) #4

I am not seeing the padlock in mobile Safari, so something is indeed wrong.

Be it Safari, Chrome, or other, the Dev Inspector should show errors for the mixed (non-HTTPS) content.

If you’re unable to find the source, you can use a Content Security Policy to force everything to load over HTTPS.


(LJ) #5

Looks secure now. However take a critical look on a smartphone - there are other issues to do with layout and some pixelated images. As we say to builders in the uk, needs a little snagging.


(Dominick Designs Websites & Tech Training Seminars LLC) #6

Thank y’all for the responses (although with mixed reviews I am slightly confused).


(Anonymous Coward) #7

Your site is definitely loading mixed content. Its visitors will not see the padlock. Use the Dev Inspector. You can see exactly what’s loading over HTTP.


(Dominick Designs Websites & Tech Training Seminars LLC) #8

thanks. I figured it out. I had the impact settings to “collapse in edit mode” so I was not seeing the other images in impact. Thank you.