Dismissing posts/threads on this forum


(Mark Sealey) #1

Previous versions of Discuss used to display a grey ‘Dismiss’ button at bottom right so that we could skip any posts and/or threads in which we were not interested.

This no longer displays; the only way to get a ‘clean slate’ appears to be to click on each thread which has a new post and return to the main menu so that Discuss treats it as read and the count decrements by 1.

This isn’t a user setting, is it?

Anyone else getting the same thing?

TIA!


(Mark Sealey) #2

For some reason, I now have to click twice on each thread once I’ve gone into it in order for it no longer to appear in New.

@Ben, @Dan - are you able to help - pleeeeeease!


(ben) #3

Judging from the amount of messages I’ve got from you @MarkSealey, I’m guessing you’re pretty fond of that dismiss button :wink:

We’ve not made any intentional changes to the forum — we use Discourse. It’s hosted with them, and I believe updates are automatically applied.

So an update could have changed something. But I’m not 100% sure.

Anyway, I have change the homepage back to show the “Latest” topics.

And I can see a “Dismiss” button on the “New” tab — I never use/noticed that button, so I don’t know if it’s supposed to show anywhere else.


(Mark Sealey) #4

Thanks, Ben - Yes, it’s a real time-saver.

Or I should say, it was.

It’s still not showing up for me. I still have to go into each thread to count as read.

Sorry and thanks for taking a further look at it!


(Jason Bostick) #5

Seems to be working for me (the dismiss button, as well as the ‘Latest’ homepage). Thanks Ben.


(Mark Sealey) #6

Latest (still) works; but it always has.

Now, though, when I see that there are, say, 8 new threads, and five of them are not ones I am interested in and/or are not relevant, I have to click on the title for each one, get to the thread, get back to Latest twice and then it will disappear from new.

20 clicks to do what the Dismiss button used to do :frowning:


(Jason Bostick) #7

I have the Dismiss button, but it only shows up when looking under ‘All’ categories. It disappears if you’re only under Rapidweaver.



(ben) #8

This must be something to do with the Discourse software we’re using — we haven’t changed any settings, and I can’t find anything about where/when/why it is/isn’t displayed :confused:


(Mark Sealey) #9

This is really strange! Still not working for me.

No matter where I start from (All Categories vs RapidWeaver) I see what you see in the second/lower portion of your uploaded image (it wouldn’t let me upload my own… stuck at ‘100%’! even though only 34K) when there are new threads

I have emailed Discourse referencing this URL and asking them to explain how the Dismiss button is controlled.


(Mark Sealey) #10

This is what I see this morning:

Does anyone know: is this a user setting or some other trick I’m missing, please?

I have to click twice on every thread in these new ones to get Discourse to count it as no longer new…

Safari 9.1 on 10.11.4

Thanks!


(Mark Sealey) #11

On the advice of the good people at Discourse, who suggest it’s a bug introduced regressively at the last update, I have started this thread for comment and - hopefully - a fix soon.

It’s now necessary to click three times into each thread to get it marked as not New!