Error When Copying To Thumb Drive


(Mark Medford) #1

Strange thing. I make RW file backups to two external hard drives with no issues, but, I’ve tried copying my project file to three different thumb drives and get “error code-36”. Does anyone have any idea what might be causing this? My file opens, saves and shows in preview just fine. Doesn’t seem like theres an issue with it. This project was worked on following the latest RW and Stacks 3 updates. I can copy projects created prior to saving after updates without a problem. Thanks!


#2

Did you check permissions on the RW6 file and also on the thumb drive ?


(Mark Medford) #3

Yep, tried three of them that I use all of the time for transporting files. Also, another file saved after S3 update copied fine. seems to only be this project file. Weird.


#4

Could it be related to the format of the thumb drive, MS-DOS(FAT32) ??


(Mark Medford) #5

I write to these all of the time, haven’t changed a thing. Just copied the same file onto two external hard drives, no error. Try to copy to one of my thumb drives, error. Can’t copy it. Nothing different about this file that I’m aware of from all of my other RW project files which copy fine to thumb. This is a tremendously important project, I’m hoping the file isn’t somehow corrupt. Confirmed again that I can open, edit, save and preview the file in RW.


#6

Did you try copying another file (say a plain txt file or something) just to confirm that there is nothing screwy with this thumb-drive ?

If that works; Try opening the project in Rapidweaver then select File/Save As and try saving it to the thumb drive.

If all else fails you could try reformatting the thumb-drive.


(Peter Danckwerts) #7

Are you using ‘apply to enclosed items’ to ensure that every single file in the RW sandwich has the right permissions?


(Mark Medford) #8

Hi @peterdanckwerts, never faced this issue before and this seems to be the only file not copying. Never done anything with permissions, could you tell me where that feature is? Thank you


(Peter Danckwerts) #9

Click the lock emblem to unlock, then the cog symbol.


(Mark Medford) #10

Did that, no options under the cog except revert which is greyed out. Don’t understand how - having done nothing different saving this project - that its not copying. Really strange.


(Pedro Perdomo M.) #11

Hi Mark,

Try this:

Best


(Isaiah Carew) #12

the problem is that the flash drive is not formated as a native Mac OS X hard drive. You can see from your screenshot that it is formatted as Fat-32.

Fat-32 drives only support flat files (no resources) and have many more restrictions on file names. For this reason there are some files that you cannot copy to a Fat-32 drive unless you flatten and/or rename them.

I don’t know the specifics of why your file won’t copy but a good guess is that there are images contained in the file bundle that have names that are not compatible with a Fat-32 drive (this is just a guess, i don’t really know).

Any easy way around that for backups, however, is just to zip the file first on your mac. A zip file not have any of those issues.

You could also reformat the flash drive to HFS+ (native Mac OS X format) and then just copy files.

Isaiah


(Mark Medford) #13

I’ll give that a try. Just so strange as I can put anything on the stick except this one file. Nothing at all out of the ordinary with the project. Thank you all for your insights - much appreciated :-)!


(Robert Ziebol 🖖🏼) #14

I think what is confusing you, is you think the RapidWeaver project file is just a file, when in fact, it is a folder that looks like a file on a computer that has RapidWeaver installed on it. Follow @isaiah’s advice and format the thumb drive to Mac OS X and it will work. :smile:


(Mark Medford) #15

That did work. Again, thank you all for your help. My biggest concern was that there might be something corrupt on the file that might come back to haunt me :-). My talent is design and I leave all of the hard stuff to you guys. For many years I did basic graphic design until I had so many client requests for websites that I had to face that monumental learning curve. It’s the brilliance of those of you who put this mystical code together that has allowed me to deliver some great sites. I can never express enough my respect and appreciation.