Fonts not showing right

I just installed ‘facebook pixels’ in the general head section. Published all pages, and now I notice that in all browsers, except Firefox, all fonts with accents (f.i. é and ç etc.) don’t show up properly?! Has this anything to do with the FB-code? Any ideas?

A URL would be helpful.

Doug, I had to remove the pixel code, because it screwed up the whole site. But I still have a screenshot, see attachment…

And this is the url of the page: https://fr.gowell.world/promotions/

I replied to the message, with screenshot and url…

thanks Doug!!

It’s probably going to be difficult to figure out what’s going on without seeing the code installed on a page.

Have you checked the browsers console for errors?

At minimum you’ll need to show the code and where you placed it.

I don’t know much anything about Facebook pixel, never seen the “pixel code” so I don’t know what exactly it is and FB doesn’t seem to give a sample in there help area.

If you want to pursue publishing a test page to get help; You could duplicate a page, uncheck show in Navigation and uncheck the index and follow boxes. Give the folder name something like test-page, and place the code in the page inspector, not the site level. Publish and give a link.

Doug

In attachment you’ll find screenshots:

  • the pixel code from Facebook (they want me to put this in the head section)

  • the head section (yellow) in my RW-doc where I had put it…

I will make a test page tomorrow and send you the link.

Milan

I’ll take a look at the test page when you have it ready,
I don’t speak French, so I don’t know much about diacriticals (accents), nor do I use Facebook. I did notice that FB help area I linked to above says:

Paste the base code at the bottom of the header section, just above the closing head tag.

The head code part RW places the code near the top of the head section. Don’t know if that’s an issue or not.

Hi Doug

At first glance, this seems to be okay… the FONTS have all the right accents…

So the solution would be to put this code not in the general head, but in the head of every page separately…

Question is: will it work for Facebook?..

I have a small second issue: why does RW make additional folders whenever I save a document, see screensaver in attachment?.. It started happening two weeks ago…

Thanks,

Milan

So it looks like you are using the Depth Theme.

I did a quick check by adding an HTML comment to both the Page head code and the Site Wide head code areas.

The Depth theme puts the “site Head” code at the top of the head section. It places the :Page Head" code at the bottom. This will Vary from Theme to Theme.

I don’t have a clue to that. I don’t use FB, The only FB accounts I have are for testing websites links. The only thing I can tell you is to test it out.

I’m not seeing that on my Mac’s. RW doesn’t have any kind of autosave. Could you have something else running, like a utility for backing-up?

Hi milan. Glad you are getting things sorted. I had posted regarding the chrome Facebook extension/plugin in your other, now abandoned, thread that discussed this issue. Essentially it’s a trouble shooting tool that will let you know if the installed pixel code is functioning properly. I haven’t used it a ton…just to confirm that some pixel code I installed on a previous site was working. Regardless, it should help. Here’s a link.

Thanks!

I am only using Time Machine… I restored elder versions of my RW-doc from Time Machine, due to the problems described here above. Might it have something to do with that?

Don’t know what is causing those folders.

What’s inside them?

Inside these folders: contents.plist - DefaultPageAttributes - Pages - Resources… see screenshot…

Yeah,

That looks like a RapidWeaver project file without the special suffix .rw8.

RW project files are really a special kind of folder called a package. macOS makes it look like a single file because the folders name ends with one of these assigned suffixes.

It looks like something on your Mac is copying your project file and giving it a new name by tacking on to the end some system generated characters.

I don’t see that happening with RapidWeaver by it self, and TimeMachine doesn’t do that for me either.

If you right click on a regular project file one of the options is to show the package contents. I bet it would match up with those folders.

Yes, you’re right Doug. It matches up with those folders. Any idea how I can stop these folders from being produced each time I save the document?

I’m not seeing anything like that.

I don’t know if anyone else has seen this behavior.

I don’t think it’s RapidWeaver but something else on your Mac.

Where are you saving the project file to? Is it on the local hard drive? Is it on a cloud service like Dropbox?

I deleted my original project file when the issues occurred. Then I opened an older version of the project file on my Time Machine backup and saved it on my local hard drive.