Known bug in Rapidweaver? Preview and hitting Command-h


(Jochen Abitz) #1

I don´t know if this is known already. but If i preview a page with command-R and pushing the app in the background at the same time with command-H, the App is freezing. Pressing cancel will force a crash.

I often run into this pit.
My fault?


(Oscar Schmid) #2

@jochenabitz

No problems using this key commands.
This happens with all projects?


(Jochen Abitz) #3

Good Question. I only work with foundation… Bingo. I tried some standard themes. No Problem. Placed a Stack page. No Problem. Foundation: Crash.

It seems to be a foundation problem.

Edit: No foundation problem. I can reproduce this on other themes too.


(Oscar Schmid) #4

It’s not a Foundation problem. No problems, also with foundation.

Perhaps, you need to repair the hard disk.


(Jochen Abitz) #5

This problem is on two Macs, both 10.11.
You have to hit command-h when the “exporting” requester is shown. Complex websites are making it easier to reproduce. And then it will occur on non-foundation websites too.

Edit: The problem is pressing command-h when the export requester is shown for preview.

Edit2: From the console if i click on the cancel button of the frozen requester:

15.02.16 13:45:58,368 RapidWeaver 6[1402]: Handling crash with signal 11... 15.02.16 13:45:58,724 Problem Reporter Sandboxed[1412]: Failed to connect (colorGridView) outlet from (NSApplication) to (NSColorPickerGridView): missing setter or instance variable 15.02.16 13:45:58,725 Problem Reporter Sandboxed[1412]: Failed to connect (view) outlet from (NSApplication) to (NSColorPickerGridView): missing setter or instance variable


(Robert Ziebol 🖖🏼) #6

Does not happen to me either. Do you have the color picker open when doing?

Edit - I do remember something like this happening to me when I had an old Hexadecimal color picker installed. Do you have a hexadecimal color picker that is represented by the hash symbol? (#)


(Jochen Abitz) #7

With or without color picker does not change a thing.

@zeebe Timing is essential for the crash. The requester has to be full shown. Mmh. Is this really my own problem?


(Robert Ziebol 🖖🏼) #8

I open the Foundation demo project, previewed the page, waited for the exporter dialog to come up and then did this until I saw the preview window and it worked everytime:
Command-H - it hides
Command Tab - Goes back to RapidWeaver.
Command-H - It hides
Command Tab - Goes back to RapidWeaver

Did this I think 6-8 times until I saw the preview of the page. No issues here at all.


(Jochen Abitz) #9

Thanky, @zeebe Seems there is a problem on my Macs.
Can i manually clean temp files of RW?


(Robert Ziebol 🖖🏼) #10

Not sure, need to contact Realmac support or hope @nikf see’s this issue.


(Nik Fletcher) #11

Please drop us a note support@realmacsoftware.com with a project file, and steps, and we’ll be able to investigate.

—N


(Jochen Abitz) #12

I am uploading the crash reporting right now… 100 MB and it is still uploading? Really?
Still reproduced it with a new demo-project (tesla-theme). I canceled uploading the crash report now at 180 MB to app.hello.devmate.com


(Robert Ziebol 🖖🏼) #13

OK, so you can reproduce it with other themes?? Maybe correct the error in your second post as it is not a foundation problem. Just so people do not get the idea it is.


(Nik Fletcher) #15

Please contact us directly via email!

Thanks,

—nik