Changing default extension from html to php lets RW 8.7 crash

I tried to change the default extension in a new project after I had already added a few pages. As soon as I type “ph”, RW crashes.

Does this mean I can only change the default extension when I start a completely new project or is there something not working properly here?

I’m able to change mine to anuthing, tested on multiple projects and no problem here.

  • RW Version 8.7 (20860)
  • macOS Mojave 10.14.6 (18G6032)

Thanks, Doug. But it is not so with my setting.

RW Version 8.7 (20860)
MacOS Mojave 10.14.6

I try to change the default in “Advanced” settings. I did a restart of my iMac, opened the project, typed “ph” instead of “html” - crash!

Well, I just tried a completely new project - it even crashes here! So, something is not right here…

Perhaps reinstalling RW from freshly downloaded file would cure this situation?

Worked OK for me although you do get a pop up warning if you delete the “html” text before typing “php”. No warning if you just overtype.