Chrome won't refresh updated page without clearing cache

There is a bug in the cache busting links option. I ran a test where I changed a single page test project; just a stack page changed the background color (six times) and republished the page only, and the resulting cache busting string was the same:

rwcache=507487490
rwcache=507487490
rwcache=507487490
rwcache=507487490
rwcache=507487490
rwcache=507487490

Once I republished all files the cache busting query string changed:
rwcache=507501940
If I then published just a page it stayed the same as the last all files:
rwcache=507501940
rwcache=507501940
republished all files and it changed:
rwcache=507502096

It seems to only updates when republishing all files. Hope this will help @dan debug this issue.

If you are using CloudFlare, you must log on and purge your cache.

Log on to CloudFlare and select caching:


You can purge individual files, but it is easier to purge everything:
**That has to happen each time you republish anything,** or CloudFlare will serve your old pages from its cache until it refreshes. If you are going to be changing a page checking it changing again then on the same caching page you can switch on development mode: This will go to your server (turn off caching) for every request for 3 hours.
2 Likes

Great advice Will, will have a look to it too :+1:

Cheers,
Konstantijn (TINO)

That’s what I did (from Will’s first post above) and it works.

I know this is an old thread but I’m still having this issue. I have CloudFlare available through DreamHost but it’s not turned on. But I’m still having Chrome cache older versions. Any thoughts? Using Foundation theme with Total CMS

Do you have RW configured to generate cache-busting links? (works only when publishing entire site) When publishing single pages I’ll actually edit the css-link myself (on server) if important enough - home page for example which is updated daily.

1 Like

I unticked the cache-busting box and republished all files but it didn’t help. When you do it manually, do you have to do it every time you publish changes?

Sorry, what about Rapidweaver 6? I just updated my website and I see no changes in Chrome (Safari is ok)
I can’t find the cache-busting links option anywhere

Pretty sure this was added with RW7.

1 Like

Thanks, I’ll search a solution for Rapidweaver 6
EDIT: partially fixed marking all pages as changed, but some minor changes didn’t update. Not so happy with this solution but at least I can display the new content