Classic Stuck in Most Recent Preview

I’m probably going to botch describing the problem I have run into, but here goes. I’m surprised I see no evidence on the Forum that anyone else has this problem.

When I’m working on changes to a Stacks page I can typically do about three to four previews of the page before it becomes “stuck” on the last preview. What this means is that I go back to Edit mode, make a bunch of changes, then go back to Preview mode, and it displays the page as it was BEFORE the changes that were made.

Once this happens I cannot go to a different page in Preview or navigate using the navbar. Plus, if I go back to Edit mode, navigate to a different page, and then Preview it. I’m shown the last page that was previewed, NOT the one I’m actually working on.

This is extremely disconcerting as the only solution I have found is to QUIT RW and restart. After the restart, I’m able to work on a page for three to four edit/preview cycles before it becomes “stuck” again.

Doing this 20 - 30 times a day is really impacting my workflow.

Is no one else seeing this problem?

I would have thought if it was widespread that something would have appeared on this forum, but I cannot find anything here. I can’t imagine that I’m the only one seeing this but I guess it is possible.

Any insights?

Hi @handshaper,

How do you preview? Using the preview tab, or by pressing command+p?

RapidWeaver uses a built-in webserver to enable you to preview the site before uploading. If the problem pops up regardless if you use the preview function or by opening the page in a browser (by pressing command+p), it’s possible that the webserver is experiencing problems.

Instead of quitting and relaunching Rapidweaver, you can also click the Restart Web Server button in the Advanced tab (left most column in RapidWeaver):

If the problem only appears when you preview the page by pressing command+p, then your browser might be showing you a cached version of the site. You can clear the browser’s caches to solve this.



I only ever use the preview function, very rarely do I preview in the browser. So this is happening using the normal preview function.

It just happened again, and I tried your suggestion. That worked, saving me from having to quit and restart the app. So thanks for that.

Should the option to start the web server automatically be turned on?

After following @Heroic_Nonsense suggestion about the web server, this problem has completely disappeared so far. After turning on the automatic starting of the web server I have had zero of the issues I was seeing before.

Thank you.



Glad it worked out!


1 Like