No Page Previews After Updating To RW 8.3

I just updated to the latest RW 8.3, Stacks 4 and updated all of the stacks that required updating. I’m running the latest Mojave 10.14.6. I can see my pages in edit mode but nothing but a blank in preview 95% of the time. It’s very unstable. Like everyone else I have jobs dependent on my web work so I’m at a standstill. Please help! I have written to RW support as well. Thank you

ADDED - It will sometimes open once upon initial opening but will not show again in Preview a consecutive time.

I suppose you have a backup of everything to go back?

Yes, but I’m hoping there’s a simple fix :slight_smile:

1 Like

Do you have in these 95% always the same stack(s) in use?

my first recommendation would be to take this opportunity to test your backup. there’s three good reasons:

  1. you seem to be in a time-pinch. using a backup is almost guaranteed to be faster than than getting help from support folks – at least as long as your backup is in good shape.

  2. it is always a good time to test your backup.

  3. this method will likely tell you a lot more about the problem than a support person will. let me explain that one…

if you go through a support person to solve this issue then they will give you whatever solution gets you back to work the fastest. sometimes that’s good – but often it will not help you understand the problem – which is key to avoiding it in the future.

the real reason that this problem is intractable without a backup or a stacks expert is that many things changed at once – we don’t know what broke – we don’t even know if it’s one thing or many that are broken. if we knew what killed things, then it would be much more manageable.

my recommendation would be to jump back a few days with Time Machine then do the upgrades a bit at a time: start with the big stuff, upgrade RW. then Stacks. then maybe a few stacks at a time.

what’s great about this problem is that you have a really clear test: open preview, if it works :+1: move on with more updates, if it doesn’t :-1: you know the culprit (one of them at least) was in the final few things you changed. then you can selectively pull that one file from time machine and get back to work.

that said, if you don’t want to go this route, or if you backup isn’t cooperative, or if you just want to see if i can figure this one out please send it to me:

this is definitely going to be a tough one for me to figure out. it could be just about anything you have installed, perhaps even catalyzed only by something on your machine, top that off with a pinch of it-happens-sometimes-but-not-othertimes and… yeah… wow, it’s a real doozy.

but go on, i bet i can figure it out. :slight_smile:

due to the challenging nature of the problem, i’ll definitely need the whole deal, here’s how to share everything with our support line:

P.S.: i have the flu at the moment. <cough cough> :face_with_thermometer:i’m kind of working half days right now. if i don’t respond immediately i’ve probably crawled back to to bed to die get better. but i think i’m on the mend and the support queue is not that bad, so fire away. :slight_smile:

Same problem here. Sometimes I can see preview, but very, very often I don’t.

I found a workaround for me: Drag a simple text stack (or any other stack) into the page and then switch to preview. Worked for me but as it is just an annoying workaround I went back to RapidWeaver 8.2.1

Thank you, I just sent the file links!

Can you explain that a bit more? Do you drag in a text box and then delete it once the preview loads successfully? For every page? Does this effect the final updated files? Thank you!

When I see preview is not loading (very often) I go back to edit mode. I choose any stack (mostly the simplest text stack) drag them into the page, switch to preview. Preview loads, I can go back to edit mode and delete the stack. That works for some time. But it is no solution, just a workaround

@isaiah The Problem has nothing to do with Stacks 4. It must be a problem of RW 8.3. Going back to 8.2.1 will fix it

It sounds to me like some of the changes to RW’s preview have had some adverse affects on some pages – it sounds to me like the page is only previewing when there have been real changes – but goes blank when RW is displaying the cached content.

One of @Mark419’s issues (still not sure if all of them) was solved by adjusting the settings in a Fade-In stack – a stack that was designed to show blank content then fade in after the page loaded – unfortunately RW’s new preview caching didn’t seem to trigger the fade-in bit – so it just stayed blank.

Just tossing this out there because perhaps there’s something on your page that is designed to show a blank page some of the time? Perhaps a fade in or slide over effect isn’t firing? If you have any effects on your page it might be worth trying to disable them (temporarily, just for testing) to see if that is the culprit. If it is, then perhaps just contacting the developer about it could solve the issue.


For now I’m eliminating the fade in stacks at the beginning of my pages. Fingers crossed that’s it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.