Disappearing images?


(tomas nittner) #1

i just continued working on an rw-file i had worked on this morning. suddenly ALL images were gone… thanks to the apple gods for “time machine”. i was able to restore the whole shabang but it somehow shook my confidence in rw #6 - to say the least. from the old times with “calamus” on atari (anybody here remember?) i am used to hit “command-s” after every operation. guess it’s a good habit also with rw #6!
happy - but cautious - weaving, tomas


(Rob D) #2

Very good habit, indeed, and better than activating “auto-save” feature (IMHO, of course)… :sunglasses:


(John Gleeson) #3

Hi, have you had any success retrieving your missing images?

I have the same problem. I could not publish direct from Rapidweaver so exported to the desktop and then uploaded via Trabsit FTP.

I’ve opened my project today to carry on further editing, and all images have disappeared and the image elements will not accept another image when I try to drag and drop them into their original places, very worrying. I found elsewhere some advice to right click on the .rw6 project file and click on show package contents. Did this and all images are missing from the file. Has exporting to desktop removed I wonder? They have different names once exported and smaller file sizes.

Any help appreciated from anyone.

John

UPDATE: I was thinking of trying to copy my original site, when I came across revert to. I tried browse all versions which filled my screen with a multitude of old versions presumably stored every time I had saved the project. Without choosing one I closed them down and lo and behold the images had reappeared in the images folder bit not in the image elements. More later…


(tomas nittner) #4

hallo @JakeLepeg, my friends over at the german forum as well as aaron from realmac software warned me not to run app’s like “clean your mac” etc. it seems, that these app’s can get pretty thorough in deleting image and other files in rw files. as i was running “clean my mac” i immediately deleted that and haven’t had the problem since. let’s hope that it stays that way :slight_smile:
greetings, tomas


(John Gleeson) #5

Hi Tomas

Thanks for the prompt reply. I also use Clean my Mac and would not have believed that it could that, I will be contacting them for their opinion.

Strange though that when I looked at revert to a previous versions the blank icons in the images folder within Rapidweaver all changed back to my photos, although they did not repopulate the image elements in Stacks 3. I am beginning to suspect this might be a bug with the autosave and versions option in 6.3.4. And I am turning this off so as to see what happens and also saving my files as a copy somewhere secure.

Whatever, thanks for your help, keep in touch if anything similar happens.

Cheers.


(Aaron Marquez) #6

Thanks @tnittner for passing that info along!

@JakeLepeg, apps like CleanMyMac tend to delete files they deem unused or unnecessary. This affects images/resources in a RapidWeaver project file, and other files RapidWeaver (project files) use.


(Christi Carew) #7

Hi,

Can you guys shoot an email to support@yourhead.com and reference this forum post? I would like to ask some more questions that are probably best done offline.

Christi Carew
YourHead Software
http://www.yourhead.com


(john springate) #8

I know this is an old thread but the same thing happened to me today with RW7and stacks. Thank god for time machine! It does worry me a lot when this sort of thing happens.


(Isaiah Carew) #9

If you have the before and after RapidWeaver projects when this happened I would be very interested to see them. If you do have that and don’t mind sharing, it would be great if you could zip them up and share them with us at support@yourhead.com.

Over the past 10 years with Blocks and Stacks there have been a handful of similar cases. The most important thing is to try to correct the problem as soon as possible.

Isaiah


(john springate) #10

Sorry to say I trashed the no image copy but if it happens again I will send a copy :slight_smile:


(Graham Jackson) #11

Not sure if it is still the case, but when I first started with RW about 18 months ago I had a folder on my server called images. The first time I published my project the images folder vanished.

I still had a version on my computer and so I uploaded it again, and re-published the project. Again, the folder just vanished. Changing the folder name to imgs cured the problem.