Filename on every page is index.php rather than index.html


(Steve Harlington) #1

I installed RapidSearch Pro2 a while back on my fixed Veerle theme and installed the stack version of the plugin on my home page. I changed the home page filename from index.html to index.php as the RapidSearch Pro 2 stack requires server side processing to return the search results.

Recently I’ve upgraded my site using Foundation for the responsive features etc.

RapidSearch Pro2 is not a responsive so I decided to remove it from my home page and install it on a separate page, however now all my pages are using index.php rather than index.html.

When I go to the stack page general setting and try and manually set the Filename field from index.php to index.html, it lets me type the change but when I tab out of the field index.html is replaced with index.php.

In Settings > Advanced I have the Tidy Website Links ticked and the extension is html

When I log onto to my host to look at my files all pages have index.php and I can’t rename or delete any of the index.php files.

Has anyone come across this before?

Much Appreciated
Steve


(Nik Fletcher) #2

It might be that other stacks you’re using require PHP?


(Steve Harlington) #3

Thanks Nik

If I create a new page it lets me use the .html extension so it does sound like an existing stack I’m using

On all the pages I’m using Partials and the index.php issue is on each page.

I’m using stacks Structure, Site Styles, SEO Helper, Top Bar, Eternity, Gradient Transparency & Logo for the Header and stacks Structure, Social Pop-Up, Elevator, Gradient/Transparency, Iconz and Text for the Footer.

I will go through removing one at a time to see which one requires PHP

Thanks for your advice
Steve


(Steve Harlington) #4

First one I tried removing SEO Helper and I can now change the page to index.html

Thanks again


(Joe Workman) #5

SEO Helper uses PHP to work its magic… why are you against using PHP?


(Steve Harlington) #6

Hi Joe

I thought the php extension made web pages slower to load as it did server side processing rather than just read the static html page that was published.

I’m happy to leave it as it is, I just more wondered why I couldn’t change it to .html.

Thanks
Steve


(Joe Workman) #7

In the case of SEO Helper, we are talking about milliseconds here. Maybe even microseconds… Enjoy SEO Helper. Use it! I promise, it will do more good for your site than the cost of 1/1000th of a blink of an eye.


(Steve Harlington) #8

Thanks Joe. I will leave SEO in place.

We all have a millisecond spare :smile:


(Dominick Designs Websites & Tech Training Seminars LLC) #9

I also thought that .php allows for loopholes for attackers?

I have a page on foundation that is not allowing me to change the filename to a .html extension. I am trying to embed html code with javascript code in the header section of the page but the page is not loading

maybe the filename extension could be causing confusion since there’s html code inside of a .php page?

Thanks for your support,


(Jason Bostick) #10

I think the page is being forced to php because of the contact form on that page (which requires php, I believe). Or maybe if you have SEO Helper on the page?

Embedding html code shouldn’t be a problem, in and of itself.


(Robert Ziebol 🖖🏼) #11

Not sure about loopholes for attackers. Joe’s site has never been hacked, at least not that I know of. The reason a page will not change from php to html is because there is something on the page is causing it. With Foundation, it could because you might be using SEO Helper, which would do it.

Now, the reason your html is not working, are you including the tags? Depending on where you are putting it, you might not need to keep them.


(Doug Bennett) #12

PHP will serve HTML without any problem. Never herd about PHP having any loopholes.
Your site is using SEO helper (requires PHP) and RapidWeaver will change your extension to PHP.

Your site looks like it is using flash to playback? Is flash installed on your browser?

What code are you putting an where?


(Dominick Designs Websites & Tech Training Seminars LLC) #13

thanks for the quick support!

yes, indeed there is a contact form on the page. That would make sense.


(Dominick Designs Websites & Tech Training Seminars LLC) #14

thanks for the quick support!

and yes, I have SEO helper and a form (signup option) at the footer of the page.

that would make sense. The reason I have this perception about php is because Joomla! is php-based and I know that sites like that get hacked often. Maybe this is just a wrong conception?

I will need to open another ticket regarding why the embedded html player is not loading on foundation. Perhaps I’ll move to the weaver’s space for that.

Thanks again!


(Dominick Designs Websites & Tech Training Seminars LLC) #15

Doug, thanks for the quick support.

I am trying to embed my radio player from caster.fm

yes, I have flash installed. Every once it a while it updates itself.

they have javascript code and the player code. I place the player code where I want the player to appear in a html stack and then I place the javascript code in the head section of the page inspector.

Is this correct? I was actually going to ask about this separately. Where should I put this code? Currently it’s in the “head” section of the html code area of the page inspector:

<script language="javascript" type="text/javascript" src="http://pro02.caster.fm:2199/system/player.js"></script>

In RW 7 there’s a javascript area of the page inspector. I am not sure if I can put this code there because of the note at the bottom of that window that states if the code is in tags then put it in the head section.

and this is the code that is in the html stack:

<div class="cc_player" data-username="duxqnkin">Loading ...</div>


(Robert Ziebol 🖖🏼) #16

Actually, your page does not need to be PHP for contact form with Foundation. It just needs to have PHP on the server.


(Dominick Designs Websites & Tech Training Seminars LLC) #17

@zeebe but that’s the point. When I change the filename to html extension then it automatically changes back to .php without a prompt or anything. I was wondering why. I guess because SEO helper is forcing it to happen?


(Robert Ziebol 🖖🏼) #18

Yes, it is SEO Helper is the cause of it, was just telling you and others that the contact form will not change it to PHP


(Joe Workman) #19

I also thought that .php allows for loopholes for attackers?

This is very far from true. Please, everyone, get this idea out of your head.


(Dominick Designs Websites & Tech Training Seminars LLC) #20

@joeworkman ok thanks for the confirmation. I guess it comes from my (negative) experience with Joomla! Before switching to Rapidweaver.