Index file left behind


(Bill Fleming) #1

I developed a website and published it which Rapidweaver created an index.html page for it. Then later I developed the same page making some changes and I added a stack which uses php code then I published it.

Rapidweaver created an index.php on the server but did not delete the index.html instead it just left it there which I had to go in to manually delete it.

Is that the expected normal behavior or it should had replaced the index.html with the index.php. I was pulling out my hair wondering why my update didn’t take hold. I thought my web cache was being so stubborn driving me crazy until I saw that the index.html was still sitting on the server.

Is there a way to prevent this happening again or I have to go in each time to delete the index.html anytime I added a stack that uses php?

Thank you,
Bill


(Stuart Marshall) #2

You can set the default page extension to be php for all of your rapidweaver pages. This is done in Advanced settings within the General settings section. There is no harm in pages that don’t need php using this extension.

And no, there is no automatic way to remove the html file when replaced with a php one (though I think RW does show you a warning to alert you to the fact that there are 2 files with different extensions). You do need to do that manually.


(Bill Fleming) #3

Thank you for explaining.

I probably just set it to force to use php extension from this point onward.


(Stuart Marshall) #4

No problem. Yes - I think that is what most folk that use stacks do.


(Bill Fleming) #5

@habitualshaker I looked at the setting and I don’t see a setting to force php extension in there. I looked in both Preference - General and Publishing. Either had this setting under advanced


(Bill Fleming) #6

@habitualshaker Never mind! Found it … You meant the page General not the preference General! Sorry … and Thank you again!


(scott williams) #7

It’s there…
ZZ123C713F


(Bill Fleming) #8

Yeah found it I was looking at Rapidweaver preference general.


(system) #9

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.