Got here on the short bus - grump


(Robert) #1

I haven’t worked HTML since hand-coding days. At first it was text based, text driven. Mosaic arrived and we all thought Andreessen was gawd. I can remember sitting around with my fellow grad drudges saying, “No more paper! Save the trees!” Goes to show you just how valuable advanced studies in beer can be.

Off topic. Sorry. Anyhow, bought RapidWeaver 7.xx. Installed. Worked a bit. Crashed. Fiddled with the plugins and such, reinstalled - joy. So off to the tutorials.

Now like the title suggests I may well not be the sharpest knife in the drawer but having hacked about with computers for a bit, I’m befuddled to learn I can’t get even the simplest of things to work. Yes - new project, new MD page. Then drag in some content. A text file is dragNdropped. Then instructor does a quick slight of hand going to the preview button to show the content. Took me a moment to catch that. Problem is: nothing shows.

Trying to follow along (next morning no program stability problems last night), I fire up RW. I have a sample txt file generated in BBEdit. On desktop and drop to Resources and first get “Error Creating Page” ***-[NSUL initFileURLWithPath:]: nil string parameter

Try twice. Go back and look at text file, return to RW and get the “Something went wrong” RW is out of here. Bang! here we are. Hey guys RW (not cheap I might add) has yet to perform correctly. Anyway, the grumbling is getting louder. I’ll try to get in touch with tech support.

Robert Sorrels
Ajo Az


(Rob D) #2

Hi, Robert,

One thing I experienced myself when I first started using RW was that habits and expectations from “the old hand-coding days” should be put to rest as soon as possible, because one might expect of RW something that this app is not meant to do or does it very differently than expected.

The web in the “old hand-coding days” and today are not quite the same thing. Things got much more complicated nowadays. So did the web-building apps (including RW).

Patience and willingness to learn and try new things are working for me and I’m sure will work for anybody else. No doubt, RW has its quirks, but this forum (troll-free and very helpful) has some very knowledgable people, so address one problem at a time and don’t get discouraged.


(Robert) #3

Rob, Thanks much for expanding on the new reality. I’ve sort of gotten it that I have to not re-learn but new-learn a tool. Along the way the outcome - once just HTML code - has greatly grown and modified. I now “get” that knowing what I knew then is only useful in the sense of knowing what systems are and have to do. What hasn’t changed is that there’s no substitute for actually having something to communicate in a moving and pleasing way. So thanks for that tip.

What I’m currently stuck on are the errors I noted above, so question? Can you - when you are building pages - just drag a text file into the resources and have it display and be available for editing? The opening tutorial shows this, but I can’t duplicate the behavior.

The second turns on the question, is RW 7.5.5 unstable? I should think, given the number of people here who are obviously using it, the software is - or at least can be - stable. Why can’t I get my copy to function properly? I culled the support email from another thread and have put my concerns to RealMac. It’s been 24+ hours, but I expect it can take some time.

So help me out. Can you drag resources into a page? If so, how? And, do you have problems with stability? Appreciate the good words and hope to hear your responses.


(Rob Beattie) #4

Let’s say you want to add some text to a page.

Add a new page using the Styled Text page type.
Type your text into the editing window
Or copy and paste it as plain text

Does that work?

Rob


(Robert) #5

Thanks for the responses. I should of mentioned that I can copy and paste into a RW page. I can also type in a new/blank page. What has me baffled is that I can’t drag anything onto a page. It doesn’t seem to matter what type of data it is. My bemusement is heightened by the first tutorial when the presenter right at the get go, drags a txt file into a page. ???

Note also that my issue is with trying to bring a “resource” in via the Resources->Drag in files… I can’t imagine that every RW resource has to be copy and pasted in place. Obviously I’m missing something, but though I’ve tried a number of approaches and searched about on the RM site I’ve not gotten an answer. Obviously, I’m not properly grasping how RW works, clearly there’s a right way to do it. Just not holding my mouth right.

I heard from Aaron and someone else about these issues. Appreciate that. The copy and paste was suggested. Aaron, on instability, suggested creating a RW document. Save, Boot to Recovery, Run First Aid. I haven’t done that whole dance yet. I did recently boot into single user and ran /sbin/fsck -f I always do this before any sort of system work which brings me to my real fear. It seems, though I can’t swear it, that I started having trouble after the 10.13.5 update. I’ve found 10.13 to be the most problematic OS X update I’ve dealt with since 10.1.5. Nothing else has complained so I really don’t know. Will try this when I get a chance.


(Jason Bostick) #6

There’s a note about this in an older post: Dragging text document from finder inserts icon which might help explain what’s happening

I’ve never had a problem dragging files into the resources section of the sidebar, though. So not sure what’s happening there…


(Robert) #7

The problem described in the link you sent is exactly the issue I’ve been having. One respondent wrote:

That is a text clipping, basically, you drag and drop highlighted text to your desktop and it turns into a clipping. that you can do, but not from word (.doc) or pages or other apps like that. IMHO that is a POOR example to show without showing how they got that text first. Mistakes like yours are bound to happen.”

I think you can see how confusing and frustrating it would be for a new user to be confronted with what appears to be an utterly natural Mac thing - drag and drop - only to find out that you first had to select not the thing but something inside the thing. Your video shows the presenter dragging a file in, not a copy. Further, the column at the left of the RW workspace says “Resources - Drag file in." I guess I’m a bit amazed that any newbie manages to get started when every first clue they get is wrong. Thanks for the help, and I do urge you to fix your video.

Robert


(Jason Bostick) #8

Have to pass you off to @ben on that one.


(Robert) #9

Well, making progress. I came into the tutorial pages from a different direction - though I’m not quite sure what I did. Here it refers to text snippets, hadn’t encountered that concept before. These can be drug in. Presenter makes this explicit. Am hacking around a bit following the tutorial working with early, early alpha stuff for the site I’m building. Let me tell you, this is going to be quite a ride. Way beyond anything I could do back in hand code days. Real nice. A particular challenge now is to select amongst all the themes. I just stumbled across the fact that I could try them on for size just by selecting each in turn. WOW! It’s like getting loose in the candy store after it’s been closed?

Thanks for the help.


(system) #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.