Linked images on smart phone question


(AZ Billy De) #1

Not sure how to ask this question BUT is it possible that a linked image does not display on a smart phone and thus the link capability is lost? I am using Foundation and the image is made smaller to fit on a smart phone and it displays perfectly using “Enter Responsive Design Mode” in Safari for even the smallest smart phone. To be clear, the image contains a link to a separate download file (mp3 or pdf). And the image itself is warehoused on the server.

Thanks


(scott williams) #2

URL?.. pretty hard to help on something like this without one.


(Greg Schneck) #3

As info only… I just turned images off in Chrome and image links showed the “alt” text as a text link. The links still work. This was on my desktop. I assume phones would be the same. But it might depend on the browser. It even worked fine with some sliders…


(Bill Fleming) #4

1611 is correct when the image is not loaded instead it make the alt text a clickable link but if there is no alt text with the image then it would display an empty box with a red X in it or some type of error box however the box will still be clickable.

A red X box or empty box will scare anyone away from clicking it in fear it might load some malware on their devices so best to use a good alt text on all your images. I know when a developer is lazy when they are hotlinking images from other sites and they didn’t realized that the other site finds out and ban hotlinks or move images into other folders which fill up their pages with red x boxes since they are too lazy to add an alt text to all the images they have stolen. :slight_smile:


(Greg Schneck) #5

This is one more thing that shows the importance of good and well thought out “alt” titles… As an experiment… turn off images in your browser and then start browsing… You’ll quickly see the sites where no attention was paid to “alt.”


(AZ Billy De) #6

Thanks everyone - very helpful!


(AZ Billy De) #7

1611mac,

Okay I turned images off in Chrome and Safari and I don’t see any images. I added a link as an alt tag but it does not show up on the page. I get an arrow if I hover over the area but I know what is there. No one else would know that there is a link there. How to I get the text link to show?

Thanks again!


(Doug Bennett) #8

I think a URL would help out here. Right now I think folks would be guessing on what’s going on.


(Greg Schneck) #9

You don’t make the alt tag a link… it will do that automatically if image is not shown. Make a linked image, add a NORMAL alt tag (text) and try it.


(Greg Schneck) #10

Here is RW setup… image has a link to google.com. Note the alt tag.

Here is the live page with images turned off… the link shows and works as a text link. The link text is the alt tag. Note that Chrome shows a broken image icon on left but the alt link does work. I’ve only looked in Chrome.

01%20PM


(AZ Billy De) #11

1611mac

Thank you for your help!

BD


(system) #12

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.