Once again: Slow SFTP connection

Still it takes a lot of time to establish a SFTP connection.
Have a look at my video to see what happens:

As already said in a former thread, ist seems to be a RapidWeaver problem.

Any ideas?

1 Like

I’m not having any issues at all with SFTP in RapidWeaver?

You can checkout my video and see:
https://vimeo.com/419351520

I am seeing the same issue. I use an ftp client to publish sites but I do user RW to pubish to my test server in my home network. Ever since the introduction of openssl in RW (8.1.7?) it takes 20 seconds to make the connection via SFTP whereas before it was instant. Because it takes so long the “lightning fast” option doesn’t get a look in as the publish is complete by the time the next connection is open.

EDIT: From testing the non closing connections issue this may be related to the version of openssl at the server end.

1 Like

Nice for you. But this will not help me solving the problem.

1 Like

Same here with Ionos as well as Strato. Since apps like Transmit do not show this behavior I still hope @dan will be able to fix this. It is really annoying but not critical (at least for me).

1 Like

I was just illustrating that it doesn’t appear to be a “general” RapidWeaver problem. A lot of RW users use SFTP every day without that issue.

Who are you hosting with?

Are you going to an IP address or a server name?

Does it happen right away after restarting RW or later after multiple publishings?

In this KB article, there are steps to clear and get the support logs. You might give that a try. There’s also info on what to send to RealMac support for help.

1 Like

Hi Doug,

If it was a “general” problem, I am quite sure that it would have been fixed already.
Im just lucky having learnt that I am not the only one.

Here are the answers to your question:

Who are you hosting with?

Strato

Are you going to an IP address or a server name?

A server name: ssh.strato.de

Does it happen right away after restarting RW or later after multiple publishings?

It makes no difference wether it’s the first attempt to publish after restart or a later one.

May be you can have a look at the log here.

Generally I agree with Jan

It is really annoying but not critical (at least for me).

1 Like

I think this would be a good one for RealMac Support to have a look at. Perhaps they can get back to you with more questions. @Aaron @tpbradley?

I can see from your video it would be annoying.

Logs don’t show any apparent issues - can you send over a fresh set of publishing logs so we can take a look? Also, has it always behaved this way for you? If not, when did it change?

  1. Go to RapidWeaver > Preferences > Publishing and make sure “Upload Logging” is enabled

  2. Now, try publishing / recreating the issue again

  3. Finally, go to Help > Copy Support Logs and paste this into a document, and send it over to support@realmacsoftware.com

Look forward to getting this resolved for you!

@Aaron Hi, this happend the moment RW changed to OpenSSL. My clients host 90% of the sites on STRATO or IONOS 1&1 and it is the same for each of them. I have send you a support log file.

1 Like

Voodoo or what? The problem disappeared this morning. Everything running smoothly.

Make sure you did not revert to normal FTP or tried a different project :slight_smile:

No. It’s the same project with exactly the same settings.
It must be Voodoo. :wink:

1 Like

Any news on this one @Aaron ?

1 Like

I have the same problem but it takes very much longer than your video, a couple on minutes some times. My main site is much bigger than yours. Cyberduck is no problem. I’ve taken to publishing it locally to my hd and uploading via Cyberduck. Hardly ideal, but it works until it is sorted.

1 Like

I made some further tests and experienced, that it works without problems from my office and is still slow at home. In both cases I use a Deutsche Telekom access, but with different routers.
In the office I use Telekom Digitalisierungsbox Standard, at home it’s a FritzBox 7590.
Strange, but this may give the specialists a hint where to look.

1 Like

I have a FritzBox 6591 but I tried it using a 4G connection from my phone and disabled all other network access - still a long wait till the upload begins and then only one connection and after a few seconds the other connections start to appear…

Which router do you use?

Standard UK BT router, new about six months ago.

It was just a guess.
Today I saw another strange effect:
If I use the VPN connection with my office, the SFTP-connection is established rapidly.
Directly it’s slow.