Redirect not working - adding / to the end


(Michele) #1

Hello. My redirect is not working. I have spoken with Little Oak (my host) and they have determined it is not a hosting issue but a website or web browser issue.

The page I want redirected is: www.shutterbugstories.com/quiz. It redirects to http://www.shutterbugstories.com/blog/files/quiz.php. However, sometimes it adds a / to the end and turns the address into http://www.shutterbugstories.com/blog/files/quiz.php/.
That causes the page to load, but not display correctly.

We tried many devices and platforms. Some loaded the redirect correctly (without the /), others an unformatted page with the / at the end. I did manage to get my own computer to load the page correctly after clearing the cache. There does not seem to be any rhyme or reason as to why it works sometimes and not others. Since the redirect works (in theory) Little Oak can not offer any more advice.

Any thoughts?
Thank you


(Doug Bennett) #2

It worked fine for me.

How are you doing the redirect? .htaccess?

Since it is working for you after clearing cache, did you have problems and make changes?


(ben) #3

As @teefers asks, are you using .htaccess or something else (PHP, meta tag, etc.)?

Either way, can you post the code you’re using to make the redirect happen?


(Michele) #4

Here is a screen shot of how I am working the redirect. I am not coding in Rapidweaver, but using my host - LittleOak

It seems to work now on my desktop, but not my phone. And it works for others, so it may remain a mystery…


(Nik Fletcher) #5

You should re-contact LittleOak to enquire about this. The redirect is happening on their server, and they’re appending the extra / to your URLs if it’s supplied. RapidWeaver cannot work around this, I’m afraid!

—N