SFTP Publishing Suddenly Not Working in RapidWeaver 8.9.1

I am suddently (last week or so) having problems connecting to my SFTP server to publish updates to my website using RapidWeaver 8.9.1. As of about a week and a half ago everything was working just fine, now I am simply unable to connect to my SFTP server. I note that I have no problems connecting to my SFTP server from the Terminal. I also note that I am able to connect to the SFTP server using FileZilla when I set the port to 22. Finally, I tried to set the server in RapidWeaver to myserver:22 to use port 22, but that does not work in either. When I try to connect I get that the initialization failed. So my settings are as follows:

Server: my.SFTP.server:22
Username: correct
Password: correct

I can still publish the updates by publishing to a local folder and using FileZilla, but I am at a complete loss as to how to publish updates using RapidWeaver.

Thank you for your help.

Port 22 is the default port for SSH and SFTP, so it’s not required to add it to the server name in RapidWeaver.

Since nothing has changed with RW (no update), something else had to have changed. That would point to the host company made changes or perhaps you did a macOS update or something else?

You didn’t provide any error messages or screenshots of your actual publishing settings so it’s hard to give you direct help.

You can go through all the steps outlined in this article and see if it will give you the answer.


Hi Anil,

I would check the hostname specified in the SSL certificate. If there is a hostname mismatch, this may cause the SSL connection to fail. For instance, let’s say the certificate is issued by the server under the server’s hostname, ssh.example.com, but you have RW set up for myserver.com, the SSL verification can fail as the hostname isn’t listed within the certificate and cause a connection issue. This is just something to check your host may be able to help or SSL Shopper.

More info:


Hope that helps.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.