RW and SFTP issues

I’ve now been bitten by this twice. My provider attempts to move my site from an FTP server to an SFTP server and RW cannot publish to it.

I run “Test” to test the connection and all is good, but when I publish, it fails on connection after the local files have been built.

Any clues as to why?

I haven’t used plain ftp for several years and have had no problems using SFTP with RapidWeaver. In fact if anything it’s much more reliable than ftp and for security I have plain ftp disabled on my host accounts.

Now without more information it’s difficult to say exactly what is causing the issue your having.

  1. You said you host company “moved you” to SFTP server , did they actually change the server? That’d be kinda strange as SFTP is ftp done through a secure shell.
  2. What did you change in publishing settings? Perhaps a screenshot of the publishing settings you are using would help.
  3. What hosting company are you using?
  4. What exact message are you getting when you publish? The “test” button I believe just does a check of basic login credentials.
  1. Yes they changed the server. They’ve switched it back to an FTP server and publishing works now, but being on SFTP would be desirable.

  2. Added the IP address of the server instead of the server name and switched to Publishing Method “SFTP” and then “Test” worked.

  1. The company is a small one, not one of the majors.

  2. The first publishing failure message flashes by too fast to see, the second reads, “unable to connect to server”.

My first thought would be to check that path. Might be okay but it’s unusual to have a path that starts and ends with the slash /.

  1. Clear out the path entirely
  2. Hit the browse button

If that works you should see a directory list of where the IP address is pointing at. If you see the pubic_html directory(folder) then just select it.

If it doesn’t work then you should get a message (hopefully it’s on the screen long enough) that might help.

As I said earlier the “test” really doesn’t test much other than the credentials so you need to dig a bit deeper.
You might try connecting with a stand-alone ftp client like transmit or FileZilla. They might give you a message that’s a little more help.

Without knowing for sure the hosting company it’s difficult to say if they might have a knowledge base that might help out. Many times host have specific requirements with SFTP such as a port number.

The only other suggestion would be to go through all the steps in this knowledge base article. It’s title is ftp but it still applies to SFTP as it’s ftp over a secure shell. Outlined is how to get a log with more details on the error.

Their SFTP server does have a port number and when I setup the credentials for it in Filezilla, that worked fine. I’ve not been able to find a spot for entering a port number in the publishing setup.

Any clues as to where it is buried?

Just add :Portnumber or ::Portnumber behind the IP address I think

I tried that already and it didn’t have any effect. Though I only used a single colon.

Are you able to actually publish with FileZilla?

  • What happens when you tried this?
  • could you screenshot the settings?
  • What port number are they using?
  • Could you show us the screenshots without the last node of the IP address and the port number applied?

The single colon should work fine example:

As my site has since been shifted back to an FTP server, so I’m not able to troubleshoot the problem anymore.

I had the option of using Filezilla to publish (I did some tests that went fine.) but I really don’t want to dump out to a local folder then upload via Filezilla every time I publish the site.

Thanks for the assist. The ticket is still open at their end so I hope they can come up with something.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.