SSL Zertifikat unter Rapidweaver einbinden?


(Siegfried Bogdanski) #1

Ich habe von meinem Provider SSL Zertifikate für eine Domain und eine Subdomain. Beider Content ist mit Rapidweaver7 erstellt. Wie kann ich die Zertifikate einbinden, so dass beide URLs mit https://… aufgerufen werden können?


(Jannis from inStacks Software) #2

Hallo Siegfried,

dies ist kein RW Thema. Du musst das SSL Zertifikat über Deinen Provider einbinden, das hat nichts mit dem HTML Content zu tun, der von RW erzeugt wird.

Abmessen sprichst Du diesen direkt darauf an.

Grüße, Jannis
inStacks Software


(Kai Hoppmann) #3

Hi Siegfried,

wie Jannis schon gesagt hat, richtet dein Hosting Provider die SSL-Zertifikate für deine Domains ein. Das geht automatisch und dauert nur ein paar Minuten. Evtl. müsstes du aber eine .htacces Datei im Verzeichnis deiner Domain anlegen mit einer Rewrite-Rule, damit die Besucher die Seite unter https://deinedomain.de erreichen.

Gruß, Kai


(Jannis from inStacks Software) #4

Stimmt, ein thread dazu:


(Siegfried Bogdanski) #5

Hallo Jannis.

Sorry, wenn ich die Begriffe nicht richtig verwendet habe. Die Zertifikate hat natürlich der Provider eingebunden. Mittlerweile weiß ich auch, dass es um diese ominöse .htaccess-Datei geht, damit die Domain bzw. die Subdomain immer mit https:// aufgerufen wird. Trotz zahlreicher Hinweise im Web weiß ich immer noch nicht, wie die Datei in meinem Fall aussehen muss (zu viele Wenns und Abers). Ich war einfach davon ausgegangen, dass RW da eine Lösung anbietet.

Zum Beispiel: Metatags sind ja auch nicht in allen Fällen ein unmittelbares Content-Problem. Trotzdem bietet RW Unterstützung bei der Erstellung an. Warum nicht bei .htaccess? Man könnte es ja zum RW Thema machen.

Gruß.
Siegfried


(Jannis from inStacks Software) #6

Ja, definitiv. Das wurde denke ich schonmal thematisiert.

Metatags sind aber immer noch Teile des HTML, wärend diese .htaccess Datei eher eine Server-Konfiguration ist.

Bei welchem Provider bist Du?


(Jannis from inStacks Software) #7

Ich benutze folgendes:

# Redirect to https

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

(Siegfried Bogdanski) #8

Mein Provider ist Hosteurope.


(Jannis from inStacks Software) #9

Das sollte da auch gehen.

Einfach .htaccess anlegen und testweise mit dem oben genannten code ausstatten.


(Siegfried Bogdanski) #10

Okay, ich hab’s.

Nach reichlich Schwitzen mit Beispiele raussuchen, htaccess hochladen, umbenennen in .htaccess, verdeckte Dateien anzeigen lassen, testen. :wink:

siegfried-bogdanski.de und betriebsanlagenplanung,siegfried-bogdanski.de

Danke!
Siegfried


(Siegfried Bogdanski) #11

Ups, Schreibfehler. :frowning:

Jetzt aber:
betriebsanlagenplanung.siegfried-bogdanski.de


(Jochen Abitz) #12

Hallo, es wird nun zwar auf https umgeleitet, aber kein Zertifikat angezeigt. Das liegt daran, dass einige URL noch auf http verweisen. Wichtig ist noch, dass sämtliche Links im Projekt auf https umgestellt werden. Das muss in RapidWeaver in Settings/General als Webadresse geändert werden. Sollten einige Links per Hand im Projekt gesetzt worden sein, dann müssen diese auch noch abgeändert werden.

Frohes Fest!


(Siegfried Bogdanski) #13

Hallo Jochen.

Herzlichen Dank für den Hinweis. Damit muss ich mich gelegentlich eingehender auseinandersetzen. Habe mich erst seit gestern überhaupt mit dem Thema SSL und Zertifikaten befasst.

Dir auch alles Gute für das Fest und für das Neue Jahr!
Siegfried


(Frank Land) #14

Ich habe meine Seite an Hand der Tipps hier, eigentlich ohne Probleme auf SSL umgestellt. Allerdings meckert jetzt Feed Validator das der Feed nicht mehr korrekt sei. ( siehe Screenshot ) Allerdings werden die URLs von RW vergeben, wobei die eigentliche Feedadresse eine http:// Adresse bleibt ( macht auch RW). Ist das jetzt ein Bug oder habe ich da was übersehen?


(Oliver) #15

Liegt vermutlich daran, dass RSS ein uralter Standard ist. Zu den Zeiten, als RSS 2.0 eingeführt wurde, gab es noch kein https, dementsprechend erkennt der das nicht. Was z.B. iTunes-Tags usw. betrifft, die gehören nicht zum offiziellen RSS-Standard, die wurden einfach so (bspw. von Apple) eingeführt. Da meckert der Validator dann nicht rum, weil es recht verbreitet ist und für den jeweiligen use-case trotzdem valide. (Ähnlicher Fall im CSS -> Browser-Präfixe oder die neuen env-Angaben für das iPhone X sind kein offizielles CSS, es wird aber kein Validator deswegen rummeckern, weil halt weit verbreitet).

Was du jetzt tun kannst:

  1. Belasse es dabei und wenn es funktioniert, dann ist es gut.

  2. Funktioniert es nicht, musst du die betreffende Links auf http setzen. Sollte der entsprechende Feed-Reader dann Probleme machen, weil ungesicherte Daten von einem gesicherten Server kommen, musst du für das Verzeichnis, wo du deine Dateien ablegst eine Ausnahmeregel spezifizieren oder das ganze auf eine ungesicherte Domain auslagern, bzw. dein Verzeichnis mit einer ungesicherten Domain ansteuern.

Happy weaving,
~N


(Frank Land) #16

Habe durch Zufall gestern festgestellt, dass wenn ich in RW unter Settings/General die Adresse bei http belasse der Feedvalidator den Feed als ok einstuft obwohl ja alle Links https sind.


(Thorsten) #17

Hallo zusammen!
Ich muss diesen Thread nochmal frischmachen, wenn auch vielleicht nicht mit den intelligentesten Fragen - dafür schonmal vorab “Entschuldigung” :wink:

Provider: 1und1. Hostingpaket: Home - für meine Fotokunstseite www.thorstenkern.com

Zertifikat ist da und eingerichtet, jetzt wollte/möchte ich gerne die http zu https Weiterleitung einrichten.
Den Code habe ich auch (zwar in unterschiedlichen Versionen) gefunden und kann mir den nach meinen Bedürfnissen abwandeln. D.h. die drei Zeilen Code in z.B. TextWrangler anlegen, speichern, die Datei .htaccess benennen und ohne .txt Endung dann uploaden.
Richtig bis hierhin?
Jetzt meine grosse Frage bzw. Problem:
Wohin uploaden???
Ich glaube das Root - Verzeichnis habe ich auch schon gefunden, aber lege ich ein neues Verzeichnis für die .htaccess datei an oder wird die “irgendwo” anders hingelegt?
Im meinem angehängten Screenshot ist der Punkt wo ich mich befinde und denke hinzugehören :wink:
Vielen Dank vorab für eure Unterstützung!
Thorsten


(Michael M.) #18

Wenn du das SSL-Zertifikat einer Domain zugewiesen hast, ist das schon mal drei Viertel der Arbeit. Je nach Hoster kannst du nun HTTPS erzwingen oder auch nicht. Die .htaccess mit der Umleitungsregel brauchst du eigentlich nur, wenn sich HTTPS nicht erzwingen lässt. Und die .htaccess kommt genau dorthin, wo auch das HTML-Dokument deiner Startseite liegt.

Wichtig ist, dass du im RW-Projekt die Domainangabe von http:// auf https:// änderst - das wird gerne vergessen. Und dann überprüfe deine Webseite auf Mixed Content (z.B. Mit HTTPS-Checker)


(Thorsten) #19

Danke für die Antwort und den Hinweis, wo ich die Datei u.U. ablegen muss - das war mir nicht klar.

  • In meinem RW Projekt hatte ich die Domainangaben korrekt geändert.
    -Das Zertifikat ist korrekt zugewiesen und funktioniert auch bei direkter Eingabe der https - Adresse.

Bei Eingabe der alten http - Version wird über alle meine Rechner allerdings immer noch die alte - zertifikatslose - Seite aufgerufen. Caches und Verläufe in den Browsern sind gelöscht…
Daraus würde ich jetzt schliessen, das providerseitig der Wandel von http zu https nicht automatisch erzwingen wird, sondern ich die .htaccess - Datei einfügen muss?

Ist das richtig gedacht, oder dauert das einfach ein Weilchen?

Wobei alle https - Checker, die ich laufen lasse, die Installation des Zertifikates bestätigen, auch wenn ich “nur” thorstenkern.com eingebe…

Hinweise bekomme ich auf Beast und Heartbleed - aber das ist wohl eine andere Baustelle :wink:


(Jochen Abitz) #20

Bei 1und1 wird keine Umleitung automatisch durchgeführt und muss in der .htaccess-Datei angegeben werden.
Ich verwende dafür bei 1und1 folgenden Code:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
RewriteCond %{HTTPS} !on
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

Es gibt da keine Wartezeit und es sollte sofort funktionieren.
Edit: Mein Code lenkt auf ohne www-subdomain um!