Armadillo and Mailchimp - blog pictures not showing up in campaign


(Rob Beattie) #1

Anyone using Armadillo with Mailchimp help me out?

Campaigns are going out but the pictures aren’t displaying - just showing the broken image icon.

Also, although all posts are by the named Admin, Mailchimp displays them as by ‘Anonymous’

Wondered if anyone had come across this and had a fix? Maybe even @nimblehost?

Thanks

Rob


(Greg Schneck) #2

I don’t use Armadillo but I’ll ask… you (or Armadillo) is “warehousing” the photo’s, right? Plus, Mail only works with Mail stacks, so can you even use Armadillo with Joes email stacks? I would think not, but again, I don’t use Armadillo. Odd as you do say you have “Campaigns going out.” (Since you are mailing campaigns I assume you are building the emails with Joes email stacks.

As for the “Anonymous”… could you provide more detail? (I use MailChimp daily and am very happy with it.)


(Rob Beattie) #3

Nothing to do with Joe’s Email stacks. It’s what Mailchimp calls an RSS-led campaign. So it picks up the RSS feed from the blog and when a new post is published sends out an email (‘designed’ in Mailchimp) to anyone who’s subscribed. Was working fine with RapidBlog (about the only thing that was, hence the switch) but is currently busted when using Armadillo.

I’m hoping it’s a simple design fix in Mailchimp but while I was waiting for the login details I wondered if anyone else had come across this before. It must be a fairly common usage.

Thanks though!

Rob


(Greg Schneck) #4

Ahhh… understood! I’ve not used an RSS campaign but you entice me to try it… And to confirm… you are seeing this on test campaigns and live campaigns?


(Rob Beattie) #5

It’s on a live campaign.


(Greg Schneck) #6

You’d have to look at the xml of the RSS feed to see exactly what is in these fields. That will tell you if it’s an Armadillo issue or MailChimp. My guess is that there is no Creator data in the xml and the image path is not a full url perhaps… but that’s only guesses. Can you look at the generated RSS feed (xml file) on your server?


(Rob Beattie) #7

Might be able to do that tomorrow. I still think Mailchimp’s the first port of call. Thanks for that suggestion though.


(Jonathan Head) #8

@robbeattie My first guess is that the URL to the images is wrong, or presented in a format that MailChimp doesn’t recognize. What’s the RSS URL?


(Rob Beattie) #9

It’s

http://www.sewquilt.me/rw_common/plugins/stacks/armadillo/feed.rss

The email previews with the picture in the correct place inside Mailchimp’s own preview but when I send a test mail, it arrives with the broken picture link icon instead of the actual picture. The picture is being added to the Armadillo post using the Insert Image button in the button bar.

Also, the email is authored by ‘Anonymous’ despite the person writing the blogs being the Armadillo Admin and using their own name when they create each post.

The bit of code in the Mailchimp template that refers to the author is this:

By *|RSSITEM:AUTHOR|* on *|RSSITEM:DATE|*

Hope you can help.

Thanks.


(Greg Schneck) #10

Hello
As info only… I setup an RSS auto mailing yesterday and received my first RSS generated (test) email this morning from MailChimp. I cannot comment as to the pic as this particular report was so long I didn’t include a pic, but in all other aspects the mailing looked good and is as I would expect from the feed I have setup. Again, that’s as info only. Tomorrows mailing includes a pic so we’ll see what that looks like. Let me know if you’d like it forwarded to your email. (PM me)


(Rob Beattie) #11

Did you do anything out of the ordinary to get the author name to show up, rather than ‘Anonymous’?


(Greg Schneck) #12

I’m sure I don’t “author name” in my feed. I set this up a long time ago using a 3rd party RSS service as my “blog” is not really a blog. I have a “faux-blog” that I do because I want to use Stacks pages, thus, the custom feed. When setup I had to define the fields based on tags and I don’t recall defining an “Author.” Admittedly, this doesn’t help you much. I just wanted to convey that in my case MC was delivering an accurate representation of the RSS feed.


(Rob Beattie) #13

Cheers for the info Greg. I’ll wait to see if @nimblehost can help.

Rob


(Gabrielle Vickery) #14

I’m about to get stuck into Armadillo to help combine my Mailchimp mailouts into a website blog format somehow (not quite sure how yet) but it’s been some time since I used Armadillo. Rob are you finding that (apart from your current issue) you are finding that they work ok together? Do you post in Mailchimp first and then use the rss and pull that into Armadillo?


(Jonathan Head) #15

I believe I see the issues here:

  • Armadillo generates img tags with a src attribute that has no “http” or “https” portion - they are protocol-agnostic URLs that browsers have no problem using; this allows images to be loaded via whatever protocol a visitor used when accessing the site, without the fear of running into a “security” warning being displayed by browsers when loading insecure assets over a secure connection. It would seem that MailChimp’s parser might have a problem with such URLs. A good way to test this theory would be to manually specify the protocol portion of an img tag for one of the posts included in the mailing to see if it displays.

  • Regarding the author issue - Armadillo does not include an author attribute in the RSS feed, which is, I suspect, why it shows up as “Anonymous” in the mailing.

Hope this helps.


(Greg Schneck) #16

As info only… Not much help here but I can say that my RSS feed has no Author and I receive no Author (“Anonymous” or otherwise) in my MailChimp Rss generated mailing.

Also, for my own future knowledge I plan on checking the image issue. I’m going to setup a manual test feed and run thru MailChimp for testing. I’ll try several “image” tag options.


(Rob Beattie) #17

Hi Jonathan,

sorry for the late reply, just getting back into this.

Can you be more specific about how I would specify the “protocol portion of the image tag”.

For example, using the post here. The URL for that photo is http://www.sewquilt.me/rw_common/plugins/stacks/armadillo/media/FlowerVaseclassproject_1.jpg

Are you saying that we should add that as the link in the Edit dialogue when adding the photo to the
blog post?

Thanks

Rob
P.S. The author issue - sounds like I’ll have to resolve that by removing it from the template.


(Jonathan Head) #18

Hi Robb,

The source code for the image in that post does not include the “http” portion; in other words, it looks like this:

<img src="//www.sewquilt.me/rw_common/plugins/stacks/armadillo/media/FlowerVaseclassproject_1.jpg" ...

Note that “http” is missing from the src attribute. What I mean by specifying the protocol is to edit the source code of the image in the content editor, and manually add that “http” portion in the src attribute. Let me know if you need further clarification about how to do so.


(Greg Schneck) #19

Rob… as info only. I created a sample RW Blog entry with left floating pic and uploaded the RSS.xml file to my site. I then created a MailChimp RSS mailing using the RSS from the Blog. I just received the MailChimp mailing and everything worked great including the picture. As Jonathan said, the feed had the full url of the image. Here is the pertinent “image” text from the xml file (you can see it’s a simple full path url):
<![CDATA[<div class="image-left"><img class="imageStyle" alt="wood-duck" src="http://www.mywebsite.org/reports/wood-duck.jpg" width="500" height="334" /></div>

Here’s a shot of the mailing received from MailChimp.


(Rob Beattie) #20

Thanks Jonathan. I’ve tried this and will let you know if it solves the issue.