Contact Form Not Sending Email - RW Issue?

Anyone have any idea why emails are not being received for me?

I have an office 365 address in the Send To field, and the site’s running on the AWS lightsail service with Plesk and dns email setting set to point to the office 365 servers. All other email stuff works, so i’m pretty sure it’s not an issue on my servers dns setting side of things.

I’ve also tried toggling the Advanced setting for “Send email using your email address”.

I’ve also tried different emails for different services, so i’m thinking it might be an issue with RW 8.5.1, if not what can I do to get this working?

Whenever I’ve had email issues before with a client using an email service like Office 365 or Google for Business I’ve had to jump through all sorts of hoops, getting into stuff that’s way above my paygrade - usually to do with MX records and such like. IME it’ll be something to do with that malarkey, rather than anything to do with RW.

@robbeattie Oh okay, so is it even worth trying to fix, or should I just re-create the form using something like formloom 4? Which should be more reliable right?

Obviously I’m guessing but again IME a change of form won’t necessarily solve the issue. That’s not to say you shouldn’t try if you already have Formloom. Or you could stump up for one of the cheap forms from Doobox or S4S and try that.

The last time this happened to me I ended up having to get a series of settings from Google for Business to add to the mail records on the server and after much toing and froing, that worked.

The default RW8 e-mail does not really work anymore nowadays, unless you are sending e-mails from the same server where the domain, used in the e-mail, is hosted. Apple’s me.com and google’s gmail.com are very generous and accept e-mails coming from almost everywhere, but mostly e-mail is being rejected because the MX-traceback doesn’t match (ip-addresses not the same), no SPF records in place, etc…

The best way is to use a from-tool in RW where you can specify SMTP login settings (as you would do when adding an account in Apple Mail), so the PHP-script can login to the e-mail server and send an e-mail while logged in. Which is basically exactly the same process as sending an e-mail with Apple Mail.

I use ‘Form Pro’ (which comes with the Foundry Potion Pack from Elixir Graphics) and ‘FormSnap’ from Yabdab. Both are stacks and have the ability to specify SMTP settings.

1 Like

Not sure which DNS record you have changed but try looking here to change the mail MX records on your domain to send to Office365


Also look at adding a SPF record, to help identify that the domain is legitimate

I’ve sense tried making a test form using Formloom 4, and just tried submitting a basic form with the default settings but did not receive an email. Also tried using the SMTP settings but also did not receive an email.

I also get this error message after hitting submit,

"Oops! An error occurred.

0 message were sent. The following addresses had problems, SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting"

Anyone have any other suggestions?

Is php mailer actually activated in your hostings php settings/offerings?

Have you had a look at the log files on the server?

I’m not sure, where would I find that setting in plesk?

No I have not, what would I even be looking for that would help me?

PHP by default doesn’t display any error messages to the end users. It will usually log errors to a log file instead.

The error messages might seem cryptic but should give a clue as to what exactly is happening to the email.

I’ve tried setting up SMTP using Formloom 4 but it’s not worked, I just get an error message saying,

"Oops! An error occurred.

0 message were sent. The following addresses had problems, SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting"

And I’m not sure what, or if anything could even help me from the link it gives.

So, where would I find a php log file?

I recently found a mailer.php file on my server, so would that mean I do have the phpmailer enabled?

I’ve never used AWS, but my understanding is that you have a lot of options on how you choose to set up.

If you’re running Apache on Ubuntu the default location would be something like
/var/log/apache2/error.log. That of course can be changed in the php.ini file.

Might have a look here

Okay, well I found that log file but of course no idea what i’m looking for, and there’s A LOT of errors.

You should be able to delete the file. PHP should recreate the file the next time it’s needed.

As I said the messages will be cryptic, but if you post some here perhaps someone can help you interpret them for you.

Well, could be a few things. Port number correct? Encryption setting coorect? SMTP authentication?
About PHPMailer: Formloom places PHPMailer in rw_common/plugins/formloom4/PHPMailer/ so not worry about that.
Here’s an example of correct settings for my hosting provider:
58

I have found the issue with help from Mike from Formloom, turns out I just had the SMTP Password wrong.

Thanks everyone for the help.

1 Like