Contents.plist' file does not exist when trying to open updated site file


(Phil Dignum) #1

I’m trying to open an older site file created in Rapidweaver 6. When opening it in 8.2.1 Rapidweaver offers to upgrade the document as normal. When I try and open the new Rapidweaver 8 document a warning pops up saying that the Contents.plist’ file does not exist. When I show package contents I can see the Contents.plist file, but I don’t know how to tell Rapidweaver that’s it’s there.

I have also tried opening and upgrading version 6 to 7, then 7 to 8, but I still get the same issue.

Does anyone know how I can fix this so I can open up the old site file please?

I’ve searched the forum and this question has been asked before, but I can’t see any replies to it.

Any help would be appreciated.


(chuck berhain) #2

Since you can see the file then locate it in the finder, select it and select “get info” from the file file menu.
You can then see the "Open with"dialog, make sure it is set to open with RapidWeaver if it’s not.


(Phil Dignum) #3

Thanks for the reply. Unless I’m missing something there doesn’t seem to be the option to set the Contents.plist to open with Rapidweaver. The app is greyed out in the list and I can’t select it.


(chuck berhain) #4

I assumed the plist file could be located in the finder and that it could be selected and then have the ownership changed. It was only a thought… If It is greyed out perhaps because RW expects it to be there but it doesn’t actually exist or is otherwise unavailable at the user level?
In the past Mac OS’s , there were options for using “Repair Permissions” in the Disk Utility App to try and resolve issues like this. That option is no longer available as it was rolled into the general “First Aid” button. You could try running First Aid but I have little hope it would help with this problem.