"Copy URL" bugs in Resources?

In RW 8.1.3 I added a number of .woff font files to Resources, to be used with Joe Workman’s Font Pro. He recommends copying the full URL to fonts rather than linking through the “Resources” dropdown in the link window. In Resources, I selected each font, and using the gear wheel dropdown, selected “Copy URL”. Then pasted it into a Font Pro link to a font. In every instance the copied URL left off the first letter of “resources”, instead showing “esources”.


Also, it let me right click when hovering over a font and select “Copy URL” but when I did that nothing was added to the clipboard.

Tagging @tpbradley for this…

@rtloon Thanks for reporting this, would you be able to send your project file to support@realmacsoftware.com with a subject of “FAO: Tom #3017”.


@rtloon Good news! I believe I’ve fixed this in RapidWeaver 8.1.4 beta, available here RapidWeaver 8.1.4 Beta 2 (Build 20634b)

I have installed beta 2 (Build 20634b) and I have no more two slashes in the og:image url BUT I now have twice the subfolder of my test site in the url.
Example :
meta property=“og:image” content=“https://www.fftst.org/test-3/test-3/resources/image.jpg”>
meta property=“og:url” content=“https://www.fftst.org/test-3/index.php”>

Perhaps I’have done something wrong ?
website address is set to "https://www.fftst.org/test-3
and path to : /www/test-3

Never mind see what you are talking about.

1 Like

NThat’s odd, could very well be something I’ve introduced accidentally. Would you be able to send your project file to support@realmacsoftware.com with a subject of “FAO: Tom #3017”.



Thank you

Thanks @annebourdon, funny enough it’s an existing problem in RW8.1.3 and earlier - there are also too many slashes (fixed in 8.1.4).

<meta name="twitter:image" content="https://www.fftst.org/test-3//test-3/resources/LogoFFTST_site.png">

I’ll get the duplicate folders fixed up for the next beta :wink:


@annebourdon There’s a fix for the path problems in the latest beta!

1 Like

Thank you.
Path problems for resources url now solved.

Thank You.
Problem solved with this beta.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.