Crash reports in Rapidweaver 6.3.6


#1

Earlier on I was undoing a change inside a Partial and Rapidweaver crashed without warning. Afterwards two separate crash report screens popped up. One says “Error on last exit” and the other says “Something went wrong…”. Both of these have now been collecting/sending crash information for a good half hour with no indication of when it will complete. In the meanwhile my computer is running really slowly and I can’t work with Rapidweaver.

Thankfully I don’t suffer that many crashes with RW but it does seem as though the crash report system has been hard work for a long time now and just never seems to complete. I have a fast 74mbps internet connection on a Mac Pro so it really shouldn’t be causing this much difficulty.

EDIT: Quick update. Ten minutes later a message popped up saying the crash report could not be sent and invited me to try again. I quit RW.


(Brian LaPan) #2

http://forums.realmacsoftware.com/t/rapidweaver-6-3-7-beta/4233


(Rob D) #3

Also, see this thread.


(Nik Fletcher) #4

There’s a 6.3.7 beta with an updated crash reporter. Would be great to know if this still affects you, with that build.

http://forums.realmacsoftware.com/t/rapidweaver-6-3-7-beta/4233

—N


#5

I just added some text to the same Partial where I saw a crash previously after attempting an undo. I tried to repeat this process and after a single undo the single “Something went wrong…” window appeared. Unfortunately I cannot type in any information to indicate what has happened or send the report because I have non stop spinning ball. RW is still present in the background and this is using the beta of 6.3.7.

EDIT: The spinning ball has now stopped after a few minutes and it’s supposedly sending information, but I was never able to properly describe the fault.

2nd Update. Spinning ball back again after I typed the last update. I’ll leave it for a while to see if it completes but it looks like the crash report has stalled.


#6

The spinning ball stopped soon after but I have now been waiting over half an hour for this report to send. On a side note when I tried the undo inside a Partial using a theme there was no problem but with Foundation it crashed with the first undo.


(Nik Fletcher) #7

The crash on undo is something that will be addressed in a forthcoming Stacks update.

Thanks for the update on crash reporter - will continue to investigate with DevMate (who provide it).

—Nik


#8

OK this just appeared but there is nothing happening at my end that should block this. I decided to quit RW.


(Nik Fletcher) #9

Thanks, will follow-up with DevMate about this.