Error Creating Page


(Diego) #1

Hello, after the update every time I add a new page (Stacks, Markdown or other) I have this error

Error Creating Page
***** -[NSURL initFileURLWithPath:]: nil string parameter**


(Rob D) #2

This has never happened to me, but I would suggest to start with a fresh copy of RW and never updating through the in-app updating process. You can download current copy of RW from this address: https://www.realmacsoftware.com/rapidweaver/releasenotes/
Just delete the RW app file from your Mac and replace it with the downloaded copy.


(Isaiah Carew) #3

It looks like an add-on or maybe RapidWeaver itself is very unhappy. If the RW re-install doesn’t fix you up, I’d recommend doing the same for some of your addons like Stacks, Blocks etc.

You can find our addons on our homepage: http://yourhead.com

Also – I always recommend: open up your addons folder and have a peek inside.

  • remove anything that looks corrupted and redownload
  • remove anything you’re not using and place in a separate folder or on your desktop
  • restart RW

Some folks have dozens of plugins and stacks installed that they’re not using for their current projects – especially when things are going wrong – I recommend just removing them temporarily. You can add them back when you need them again. Keeping things to a simple set will make RW run faster and smoother.


(Diego) #4

Thank you for the suggestions.
I downloaded a fresh copy of Rapidweaver from the site, but it is the same.
Now I will look at old addons to remove.

Searching with the words of that error I found this topic:


(Isaiah Carew) #5

Yes, that thread. :pensive:

Unfortunately the user never contact me – and other forum members derailed the conversation – the result was… nothing… I do not know if the user worked through the problem or if the problem was solved, or what caused it.

But my suggestions are the same. First clean up your plugins, if that doesn’t seem to solve the issue, please contact us with your project file and we can take a closer look.

http://yourhead.com/support


(Patricia Dubois-Violette) #6

Yesterday I updated RW 6 to RW 7.5.5 and when I try to create a new project I get “*** -[NSURL initFileURLWithPath:]: nil string parameter” too.
But first I tried to convert 3 files under RW 6 to RW 7 and only 2 work properly. The 3rd one refuses to preview and crashes.
I work on a recent MacBook Pro under Mac OS 10.13.4.
Can I get some help ???
Thanks in advance


(Doug Bennett) #7

Most of these kind of errors would be best addressed by RealMac support