Error using SSL on site


(Gary Balfour) #1

My site, made with Rapidweaver 8, works fine until you try to view it in https. I used the secure link in the general settings. There was an .htaccess file to force redirect. I have suspended it temporarily, but if you click on the logo, it would bring you to https.

The site is www.africasbestsafaris.com. Any help on what I have done wrong would be appreciated.

Thanks!


(Paul Dennison) #2

Can you post the contents of the .htaccess file, as the rewrite definitely doesn’t work (tried on chrome on windows 7 at the moment).


(Gary Balfour) #3

Hi Paul

The .htaccess is

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.africasbestsafaris.com/$1 [R=301,L]

But at the moment, that should be disabled.

Thanks
Gary


(Doug Bennett) #4

You have Active Mixed Content on the page.

http://netdna.bootstrapcdn.com/font-awesome/3.2.1/css/font-awesome.css
http://code.jquery.com/jquery-1.8.3.min.js

These are probably from the Theme you are using(open?).
When going to SSL (HTTPS) you need to make sure you check for mixed content before you do the redirects. Active mixed content will break the page(s).
Check here:
https://www.whynopadlock.com


(Gary Balfour) #5

Thank you Doug. Let me work on resolving that.
Best regards
Gary


(Gary Balfour) #6

Thank you everyone for your help. The issue was indeed the template uses and Nick Cates sent an updated template that uses secure links. All is resolved.