Problems implementing SSL error code correction message


(Bernard O'Sullivan) #1

Hi All

I am latest RW, using Feather theme and stacks. I have just purchased an SSL certificate to assist in my Google ranking.

The SSL version of my site features a black padlock just before the URL, which I right clicked on>Inspect to reveal the error information in the attached screen grab.

I have no idea, what these messages mean, or how to make corrections for this site and others to come to be 100% SSL friendly.

Is there anything in RW or another plugin that I might not be aware of that can fix these errors for me.

Any advice would be brilliant as I have paid for SSL but can not fully implement it.


(Doug Bennett) #2

judging from the messages in the screenshot you have mixed content. It appears the “favicon’s” are using an HTTP address not an HTTPS. Did you change the site URL in settings to use HTTPS instead of HTTP?

For the other errors(uncaught type error), it would be much easier if you provide a URL to the site.

There are lots of posts on this forum on converting sites to SSL. You can search the forum for SSL or HTTPS and get lots of info.
In general, the steps are as follows:

  1. Get and install Certificate (free or Paid) - you have completed this step
  2. Check the site and fix “mixed Content”. (Active mixed content has to be fixed or site will “break”)
  3. Once the mixed content is taken care of then. redirect all traffic to HTTPS.
    • This is usually done with a .htaccess files depending on the host company

(Bernard O'Sullivan) #3

Thanks for your help. Is there a tool or guide on how to fix the mixed content and any other errors listed?


(LJ) #4

Firstly, As @teefers suggested, make sure that you have https:// and not http:// in the publishing settings of your Rapidweaver project. This should sort the 3 favicon icons in your resources folder.

When this is done, ‘force’ https in your .htaccess file. If you are using RW8, go to publishing settings and click edit htaccess file. if there is one on the server it will open. Add the following code:

RewriteEngine On
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} ^www. [NC]
RewriteCond %{HTTP_HOST} ^(?:www.)?(.+)$ [NC]
RewriteRule ^ https://%1%{REQUEST_URI} [L,NE,R=301]

This will force https and the non www version of your site. In other words, for example, if someone typed in www.insiderphoto.co.uk it would resolve to https://insideoutphoto.co.uk

If there is no htaccess file created already, I’m not quite sure if RW8 will create one. I suspect not. If not you can create one manually: Go to your server and put a plain text file there called .htaccess. This can go in the same folder as all your Rapidweaver project files (often called public_html or similar). It may work in the root folder also - I’m not sure. You can also create a .htaccess file in cPanel and other interfaces. Be aware that ‘dot files’ are by default invisible on macs and in cPanel so you may want to make them visible in order to see the files location.


(Bernard O'Sullivan) #5

Hi There

What can I say, clear, concise, thorough advice that I was able to understand and implement.

Many, many thanks


(LJ) #6

Excellent - and you have some fine photography on the site. I’ll keep you in mind if any of my clients need your kind of work


(system) #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.