File extension - set to php but still publish it with html


(Bill Fleming) #1

Yesterday I developed a new page and first thing I did was set the extension to php in advanced under General but it still published it in html - index.html

This is the first I seen it happened. Any idea why it ignoring my setting and publishing it in html? I am using Joe Foundation template and stacks

Thank you
Bill


(Brandon Scott Corlett) #2

Does it still publish as html when you remove the HTML file from your server?


(Doug Bennett) #3

Nothing I know of would cause an extension to change back to HTML from PHP. Any stack that requires PHP would change the extension from HTML to PHP.
You should get a warning message when you publish about duplicate index files.


(Bill Fleming) #4

I am not sure if it punish anything but It could use a good spanking for not behaving as intended when publishing. :smile: However it still publishing in html when I remove it.


(Doug Bennett) #5

What’s the page inspector say now? PHP or HTML?


(Brandon Scott Corlett) #6

HAHAHAHA :joy:

Dang auto correct strikes again.


(Bill Fleming) #7

Strange it say html now, going to change it to php then.


(Bill Fleming) #8

I remove it and publish it. This time I got a warning of multiple index file but it did not publish either html or php. It didn’t publish a index file at all.

I am going to try force re-publish next. My RW isn’t being nice to me this morning!!


(Doug Bennett) #9

If you created the page before settings the General setting (this is for future new pages) it will still be HTML. You need to change pages that were created before setting the default manually in the page inspector.


(Bill Fleming) #10

Sigh … I was looking at my mirror backup directory of my website not my actual website directory. :blush: The index.php is now created and there. Thank you all!


(system) #11

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.