Galleries in Majestic Theme


(Tomas Jakobs) #1

Hi Rapidweavers, not sure if this is a bug or not but I have a problem with galleries.
Within Majestic Theme I would like to use a gallery with captions in full size view.

These are my settings:

And this is what I get…

I am missing something?


(Brad Halstead) #2

@jakobssystems

Hi Thomas

It’s not over-layed captions, the captions replace the Gallery Setting of Description and are set for each image in the add image pane in edit mode by double clicking the Caption field of the image. Scroll up to see it with your nav buttons. or preview in browser instead…

Hope that helps
Brad


(Tomas Jakobs) #3

this is not the problem…I am talking about the caption and I’ve exactly filled them out in the caption column you described… the theme does not display it.
But it does shows the caption when selected “Everywhere”, then I see this: The correct view with caption lower left…


(Brad Halstead) #4

@jakobssystems

I didn’t catch you were using a lightbox… sorry… can now duplicate… you found a bug… @Elixir

The proper description would be (to the Developer…) When the Use Master Style is disabled and enabling Photo Album Lightbox on a Photo Album Page, the Captions do not display when full-size image only is selected, will only function when everywhere is selected when using a lightbox.

Have included Adam in the thread (Developer)…

Brad


(Tomas Jakobs) #5

ja this would be the perfect description :wink: thank you very much…


(Adam Shiver) #6

The theme’s lightbox only has access to the caption from the thumbnail itself. So in order for the lightbox to grab that caption info and add it to the lightbox (which isn’t a function of RW itself) it must be enabled for the thumbnails (or everywhere), otherwise RW will not output the caption data.

That being said, you can use this bit of code (along with enabling the captions for the thumbnails) on the Photo Album page in the Custom CSS field inside the Page Inspector to perform a bit of trickery.

p.thumbnail-caption { 
    display: none;
}

.thumbnail-wrap {
    margin-bottom: 5px !important;
}

(Brad Halstead) #7

Nice solution @Elixir, thank you!

I hadn’t seen that requirement in the docs for the Theme. Sorry if I missed it.

Brad


(Adam Shiver) #8

It isn’t in the requirements or anything. I had been adding a feature to turn off the thumbnail captions, but no one seemed to be using it. So I went without it this time. You’re the only one to need that option so far. :wink:


(Brad Halstead) #9

@Elixir

Haha… figures… I can see the option useful when making a presentation of a new featured lineup of say vehicles where you would want to show the manufacturer, model year and name of vehicle… in my case, the 2016 Harley-Davidson® Lineup

Another example may be pictures of Harley Owners Group® chapter rides, but that can be done via the thumbnail page, or if I wish to be more descriptive, I again can use your solution.

Your solution works for me though so no issue. I’ve bookmarked it incase it comes up again.

Thanks again Adam
Brad


(Tomas Jakobs) #10

Thank you Adam… your workaround works perfectly…thank you very much for your quick support!
http://www.ul-fortbildung.de/touren/nordsee2015/


(Adam Shiver) #11

No problem at all! Glad to help out.


(Tomas Jakobs) #12

Sorry for another question: Is there also a CSS workaround for the position of the menu button. It’s fixated on the right side even when the menu opens up on the left side. I would like to have both menu button and menu on the left hand side.


(Adam Shiver) #13

No, sorry @jakobssystems, that is not an option. You can place the menu itself on the right-hand side via the built-in options though.


(Tomas Jakobs) #14

Just recieved your Majestic Update with left Toggle Menu! Thank you very much this is what I would call great customer support! Adam you are my hero! You made a really great job!

And here’s your theme “live in action” (in german only) : http://ul-fortbildung.de

Thank you very much!


(Adam Shiver) #15

No problem @jakobssystems. Trust me, you were not the only one that was interested in that feature. I would have gotten it in the first update back on Dec. 28, but I just didn’t have the opportunity until now.

Your site is looking great! Very nice example of Majestic in use!!