Google Analytics not showing in head

On the instruction of a Google operative I pasted some Google Analytics code into the Head section of my site and published. It didn’t show when we checked it. Any idea what I might be doing wrong?

Using RW 8.5.1

Have you cleared the cache of the browser you used to check it with? If not you might be seeing the “old” version of your site before the changes were made.

1 Like

Could you provide a URL to the page?

When you say “it didn’t show when we checked it”, how are you checking?

Without knowing what you pasted into the head section it’s not easy to tell what might be happening.

Thanks for your replies. I’ve cleared the cache and reloaded the site and the code is still not showing in the Head.

The URL is

I pasted this in

I don’t see anything that looks like Analytics(gtag.js) in the head section.

The code should have looked something like this:

<!-- Global Site Tag (gtag.js) - Google Analytics -->

... (several lines of customized programming code appear here)


if the block doesn’t look. like that then go back to the “Google operative” and get the proper code.

Since the first line that google gives you is a comment <!-- Global Site Tag (gtag.js) - Google Analytics --> and that’s not even showing up it could be that the publishing didn’t work. Could you change something else on a page and check to see if it shows up?
More info is available here:

When I try to paste the Google code into my post on this forum it doesn’t appear in the post. (I tried clicking the code button above and it says to indent the code by 4 spaces. I did that and pasted the code but only the first line shows in my post, so I’m not sure what it is I am doing wrong.) The Google analytics code is definitely there in the Head section of the Code window. Here’s a screenshot. If it isn’t getting published what can I do about it?

You can’t post code onto the forum without marking it as code </>

That code isn’t showing up on the URL you gave above.

Ok I did that - just one word on the Home Page, and although RW gave me the message that it was published it doesn’t show up online.

Assuming you have cleared your browser cache or checked with a different browser, that tells us you’re having a publishing issue.

If you aren’t getting any error messages when you publish, double check the path in the settings.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.