How do I link to an anchor on another page?


(Gary Davis) #21

Zeebe – You are not REALLY Spock, are you? THAT FIXED IT! Two clicks! Thank you, thank you.
Why, do you think, that publishing and republishing via the button at the top right would not do that? That does not seem right. Boy, do I owe YOU a beer!


(Robert Ziebol 🖖🏼) #22

If you are using RapidWeaver 6, then Republish All Files is in the publish button, see my screenshot:

What is weird, is that when changing the folder name, it should have republished the correct files, not sure why it would not. Glad it is working. Have a great day!


(Gary Davis) #23

Well, my site is back up as it was, looking good again, which is all that is important right now. BTW, I did try that Joe Workman Anchor thing again. Still did not work. So, changing the name of the page to the page I was linking to (duh!) did not fix the problem. I asked Workman Support about it, and I will report back here what they say. For all I know, the thing may be just too old to work. At some point, I will either learn how to use it or learn how to do it another way.


(Robert Ziebol 🖖🏼) #24

Hey Gary, I do support for Joe, and replied to your email you sent it. As shown above in my link:
http://www.zeebedesigns.com/anchor-199/
I am using the anchor link.

I would give you the project file, but it is made with Stacks 3 beta. If you use that, I can send it. I believe I asked for you to send your project file to me in the support ticket, if you could do that, I could see what might be going wrong. I will try to make an working example in Stacks 2 tomorrow, that is on a different machine than I am on right now.

By the way, have you looked at the docs page for the stack:
http://docs.joeworkman.net/rapidweaver/stacks/link-anchor
See if that helps at all.

We will get this figured out.


(Robert Ziebol 🖖🏼) #25

Just to let everyone know, this is the URL that Gary needed:
http://austinracewalkers.com/tips.html#diet
go ahead and click on it, it brings it to the right spot. We solved this one!!


(Mathew Mitchell) #26

Yeah! Congrats, and thanks for helping him out @zeebe


(Gary Davis) #27

Hooray! Thank you VERY much! Well, I was pretty sure it would turn out to be some little thing but, actually, it was a couple of them, right together. I had not A. included the “.html” with the name of the page and B. I had put a forward slash between the page name “diet” and the anchor name “#diet”. Would not have come up with both of those, ever, I am pretty sure.

Internal links on both my sites shall now proliferate!

One question, zeebe: In the little “cars” project you made for me to show me how to do this, in your links, you do NOT use the “.html” after the name of your page and you DO use a “/” before the anchor name. And yours work. So, why was there that difference?

I am pretty sure the answer to the first part is that you use a folder named “cars” and then “index.html” for the actual page. I just use “tips.html” off of “/” for the path to it and don’t put it in a folder. (I don’t really understand the folder thing for pages now but maybe I will get there at some point.) No idea as to why you use a slash but I do not. Maybe this is one of those things that my mother used to say about: “Just don’t think about those things – they’ll drive you crazy!”


(Robert Ziebol 🖖🏼) #28

You are right, I made a folder named cars, and since you do not need to add the index.html, you can just use
http://www.zeebedesigns.com/anchor-199/cars/
when you use a folder, you do not need to add the index.html or index.php (if your page uses php code).

Using folders makes your URLs look neater (at least I and others think that). So if I did not have a folder named cars, my URL would look like this:
http://www.zeebedesigns.com/anchor-199/cars.html
but because of what RapidWeaver calls Tidy Links, your URL does not need to include the index.html.

Hope this all makes sense, it is late for me and I think I rambled…


(Gary Davis) #29

It kind of makes sense, except that I notice in your link, you have the anchor before the name of the page and a forward slash between everything. But in my anchor link, the name of the anchor came last and there could be no slash between the page name and anchor name, or it wouldn’t work. Seems as though, there is always a slash in there before the anchor name, but not when I do it. My link was website.com/pagename.html#anchorname . And that works. (I stashed that info in several places, as you can imagine!)


(Robert Ziebol 🖖🏼) #30

Actually, the anchor-199 is not the anchor, but another folder my site is in. I do so many demo pages for support, that I always make it go in another folder in my server.


(Scott Frankel) #31

Hi Zeebe,
I have just read this thread and still confused. I am also using JW Link and have placed it half way down a page on another page to where I am putting the link button.
I have attached screenshots, should this be the correct way to link? http://test1ef.rapidwebsites.net/articles/parenthood/
All help and advise welcome.
Many thanks
Scott


(Jason Bostick) #32

The URL isn’t working for me to test exactly, but you need the ‘#’ symbol in your URL.


(Scott Frankel) #33

Hi Jabo,
Would that be in front on parenthood?
Thanks for your help


(Jason Bostick) #34

Yep. So, example.com/articles#parenthood or
example.com/articles/index.html#parenthood or
example.com/articles.html#parenthood

(depending on how your rapidweaver settings are)


(Scott Frankel) #35

Thanks Rabo,
Tried both with http://test1ef.rapidwebsites.net/articles.html#parenthood and also without the .html but still no luck??? See screenshot below,
I am just not sure how this JW Link works, I’ve read his documents and read forum threads but this little stack just seems to be a tricky little thing.
Any ideas or thoughts welcome.
Cheers Scott


(Jason Bostick) #36

I can’t get your URL to work on my computer to look (even the test1ef.rapidwebsites.net/ does not show up for me).

If you hover over your link, what does the URL say in the bottom left of your browser?


(Scott Frankel) #37

Hey mate, I really appreciate your help and responding so quick.

I don’t have the site uploaded at the moment, I’ll do that shortly to test but in RW this is the link I get when hovering…see screenshot


(Jason Bostick) #38

Hmmm. I know I’ve used that stack in the past and haven’t had issues but I’m not at my RW computer right now to check settings. The only other question, maybe, is if the page is set to .php instead of .html?


(Scott Frankel) #39

Ok, thanks. I’ve just uploaded the test site
http://www.testef1.rapidwebsites.net
I did check, it is definitely html not php.
When you look at the site, the article link buttons are on the home page. The one for Adjustment Difficulties is just a normal link to the Articles page, which opens to the page fine. The other one Stress and Worry is where I’ve tried the JW Link to try and have the page open halfway down so that the page opens at the article rather than at the top of the page.
Many thanks for your help.
Scott


(Scott Frankel) #40

Sorry mate they buttons read Parenthood and Intimacy and Desire…not Adjustment Difficulties and Stress and Worry…which is how I feel!!
Cheers